App opens to add device

For several weeks now the Wyze app opens to an add device page so have to wait up to a couple minutes for normal homepage with cameras . A couple weeks ago I could click on events and back to home to pull up my list of cams but now going back home still shows add device page for a minimum of 30 seconds rendering live views impossible up to a couple minutes. Reinstalled app per customer service and still a major hassle. Ideas?


And you force close the app between uses? My only trouble shooting thought would be to uninstall, restart phone or device, then reinstall app. Are you on beta app or production app? What Android device are you using?


I would say the production app, from from Google play. Tried to load a screenshot and only the file name appeared, not sure if that’s normal and pic appears once posted. Phone is newer Samsung S10, I’ll try your suggestion, thanks.

Wait, are you saying I should do a force stop after every time I use the app?

Did you ever sign up for beta? If you did you’d still get it from the play store. What app version are you on? You can get that either from in app or through Android. That’ll tell us either beta or not.

Was curious and For trouble shooting, to see if the app starts fresh or not, or if it’s running in the background and your just recalling it and not actually starting it. To see if it gets fully closed or not.

Sorry for the delay, got called away. It’s v2.13.119. Oh okay thanks, I understand on the force stop. I did that and reopened the app. Funny thing, so far the add device screen just flashes a couple seconds then it goes to normal home screen. And I don’t think I signed up for beta as in the very beginning of V2 cams. Only had them about a year.

1 Like

Not beta, that’s the production version. Glad the force close helps, have you uninstalled, restarted phone and reinstalled yet? I wonder if that’ll help more.

No not yet, delaying since uninstalling it always makes me nervous haha, but will do it now.

Hold on one second…

I was thinking that your app opens to this page…

But does your app actually open to show only the prompt to add a device? Not the actual add a device page?

Like this:

Yes it’s your second picture, the prompt to add new device.
Mostly white screen with that green add device in the middle. I was busy uninstalling,shutting down the phone and then restarting it and reinstalling the app. Unfortunately when I opened the newly installed app, it kept the New Device prompt page up for 32 seconds. Force stopping shouldn’t help since I’ve only opened it once but maybe could try that again.

I get the 2nd picture also for at most 2-3 seconds then my devices populate. Sorry I thought you were getting a different screen when you started up the app. The wierd thing is how long it lasts for you. I’ve never had to say, go to events and back to home for it to " log in". Does it act the same when you are connected to home wifi, or mobile data only, or a different wifi network?

Thanks for sticking along for the ride, sorry we are taking a little bit of a scenic route. I’ve had convos with other that this happens to also. It seems to have started with a recent app update.

Oh that’s good to know, that others have that page stick on. Got silence for a minute from customer service and no other info than to reinstall app so thought it was really unique to me or something. I just opened it to see if I should try to force stop before writing you back and I’m not going to because it just flashed that new device prompt page and went to home page. Really appreciate your help and will do the force stop again if that irksome page starts sticking longer than a flash.

1 Like

Have you tried going mobile data only or different wifi network to see if it’s a network speed or lag issue?

Glad to help, sorry couldn’t fix it 100% for ya. But your not the only one with this. :slight_smile:

Good question. I use Wi-Fi mostly and can’t recall if it sticks on that prompt page or not. Seems like when I was out the other day, on at&t cell service, it did. But I’ll note it next time I’m away and check on Willow, the chocolate empress on high haha…chocolate lab.

(Just turned Wi-Fi off and if it actually wasn’t connected then on mobile the app opened the same with just a couple seconds on that screen. That page haunts me since I heard footsteps outside and couldn’t view the cam, thought that prompt page might be the last thing I see). :scream:

1 Like

I get that as well. It has only started doing it in the last month (I have updated to the latest firmware and app). It shows none of my cameras for a few seconds, just the green + New Device button, and then shows them. On the longer waits, it gets worrying as I worry that all my cameras have disappeared but they eventually appear. Also sometimes, it doesn’t show the names of my cameras, just a string of upper case letters and numbers, even in the Events page. It’s like it’s waiting to receive the details of my cameras from a remote/online server, before I’m allowed to access them. After the cameras appear, I usually have to wait up to 10 seconds for the thumbnails to appear but I don’t mind that.

The suggestions used to work but it’s gotten even worse today stuck on that dumb New device in the green bubble page. I wait over 2 minutes and close it though, Don’t know if my home page with all my cameras will come back up, did the requested updates on a couple cameras today. Have force stopped, restarted phone and app etc. Ridiculousness.

This is ongoing right now.
Keep up with this thread for updates.

1 Like

Well your updates have made my Cameras useless. My cams aren’t there Click on Wyze and it opens to Add. Sometimes I can see my Cams But the app shuts down after a few minutes. Click on Events and it may show or shutdown.

There was a service outage that has been fixed but service to some areas is still catching up.


This was unrelated to an update, although still frustrating