App all of a sudden chg'd?

All of a sudden my latest version of the Wyze App (Android OS )(ph model - ZTE Blade A7 Prime ) has chg’d, for the worst.

I tap on the app, it starts, then turns on a black background with puke green letters “Wyze” .
Then asks me, to sign in.

When I do, it goes into a browser selection request and leaves me hanging thrre (if I am lucky).

I have tried the following -

App Force Stop
App Delete & reinstall
Reset my phone
Check for Goo Play store tore Updates (none)
Cleared Play store cache

What is going on ?

That’s the new startup image. Look carefully in the black and you will see images of many of hte Wyze products.

What do you mean it goes to a browser selection request? I just logged off, Force stopped app and then restarted to make sure I was not missing something in the process. It never goes to a web browser. In my case, I have 2FA using Google Authenticator so after logging in, it asks for the 2FA code, but never goes to or requests a browser.
So what do you mean?

It’s a bit better now.

But, I have never had a browser selection offered to me, Especially before I can get to the sign-in screen.

I selected Goo Chrome n signed in.

Last night, even that did not work after several attempts.

Today it worked.

There were no images on the solid black background.

Maybe for btr security & piece of mind, I will switch to 2FA ?

I never sign out .
Goo Play went offline too. (Now restored)

I have a screen shot of that browser selection request, . That itthe forum now, is not letting me upload it.

I guess, as long as the App via browser works ?
I will survive.
But something is going on here.

I’m no newbie, I’ve been with Wyze when the only offerings were Cams V1 & V2.

Had & have been using the app & posting to the forum ever since.

And we still have 23 days to Halloween ???

Thx anyway for the reply.
U never know, how much one would miss “Wyze” n the apps reliability, that’s until it stops.

If you are having problems with the lastest App version, you could try an older version available here.


I totally forgot about that option.


That new Browser Splash Screen at login that Wyze is using came along as a result of the addition of the Google and Apple OAuth login options. I am still on the fence about liking it or not. Had some major snags in the 2.46 Beta, much like you experienced, and had to sideload an old version to get back. Was not a pleasant experience.

1 Like