Apologize in advance but getting 404 NOT FOUND

Hi everyone,
I’ve searched for the firmware for wyze cam V2 but am getting an error message. I tried both from the youtube link and searched here as well but don’t see it. the reason I’m looking for this is that my V2 has solid yellow light and I’ve tried everything else with no success.
It would be greatly appreciated as im about to throw it against the wall :wink:

Thanks in advance.

Okay, i found it and have it downloaded it but its showing as a video file {wants VLC Player to open it. :frowning:
I’ve unzipped many files before but i admit it has been a long time since I’ve done it since the tablet days.

PS- im Canadian so support won’t help or replace my newest camera so this is my only choice besides throwing it into the garbage. i do own 3 V2s and 1 cam pan, along with the sense set up kit.

What file did you download?
Are you trying to unzip it on a Windows PC or some type of tablet?

How to flash firmware


Hello and thank you very much for the reply.
I downloaded the V2 firmware but when I unzipped it on my (1 and only) laptop, it showed as a VLC media file!? So I made sure the default wasn’t set for VLC for bin files and it wasn’t, even reset to default for everything but it still showed as a VLC file and when clicked it couldn’t be played as it’s an unrecognized file.

So I thought to google it even though I’m not sure what I’m actually dealing with and saw that this isn’t an isolated case, it seems to have happened a lot back in the day and still today, I guess. Followed links to research and it was all stuff I wasn’t comfortable with doing due to my transition to tablets and big phones. Then. I found a program that said it could do it without messing with the registry so I tried that and I was able to get the VLC media file removed but now it’s just a plain old up openable file. Then after more quick and not thorough research I download PowerISO as many said it worked for them but now it will not recognize the file at all. I’ve deleted and reinstalled everything and am even trying a system restore (which I regret as it’s been awhile now) and here is where I am currently.

The V2 was working, then would drop off line with the famous error 96 (or 99, the main error message when can’t connect) and when I would re add it to my set up it would drop off again. I reset the modem which obviously isn’t the issue as I have many other Wyze products working fine.

I have tried everything possible right now and am hoping some computer genius might see this and take pity on me and tell me it can be easily fixed (I’m dreaming, I know). Thought about getting it from a cloud but that doesn’t seem to be an option. No other PC to try it on either. Broken Wyze Cam and now messed up laptop. The luck on the (non) Irish. :joy::cry:

Just to put it out there in case this helps. I was able to partially set it up a few times but it could never recognize my network, which works with all my other Wyze products, but reset it but no go. Then it just stopped the prompts and setting up (partially) and now just has a solid yellow light. Passed the time frame for return to amazon, unfortunately, even though it’s fairly new as I bought the camera/sense kit off of Amazon for about 80.00 or so.

I also tried other power bricks, supplies, cords, everything that’s been suggested off of the Wyze site and web.

PS-Wyze employees, please fix your firmware links on Facebook and YouTube as they both come back as 404s. Doesn’t help someone who’s already in a bad situation when company help video links do not work at all.
(Rings a bell and yells “Shame! shame! Shame! at you guys) GOT reference. :bell:

Did you read the instructioons on flashing the firmware?
The .ZIP file contains a .BIN file.
If you have Windows set to not show extensions you won’t see the .BIN extension but that doesn’t matter.
You shouldn’t be trying to open the .BIN file with anything. It doesn’t matter that .BIN is associated with VLC.
All you have to do is change the name of the file to DEMO and copy it to an SD card.

There are several V2 firmware files.
The most recent is: V4.9.5.36 (November 15, 2019 )


Hello and thanks again.

Yes, I did follow the instructions as much as possible. When I open the zip/rar file to get the bin file with either poweriso or winrar it will not extract anywhere.
This seems to be a common problem on google search but it takes a lot of command prompts and all that jazz to fix the issue which I’m not good at. Right now my laptop is still trying a system restore which hopefully will fix the registry.

I apologize if I’m missing something here. I’m a bit older yet tech savvy but I’m also suffering from a chronic illness in a somewhat bad neighborhood. It just felt safe to have a cam on my doorway as I’m bed ridden for the most part.

I guess I’ll just stop stressing over it and toss it away. I just feel ripped off a bit for getting a faulty unit. All others are still working well so far. Even have Amazon routines for door sensors and motion detector set up which I absolutely love.

Thank you again and if anyone can think of a simple solution or something I’m missing please let me know.

Cheers and enjoy your day.

I’m sorry for posting so often but I read somewhere that if you unplugged the camera for 12-24 hours it helped some fix their problem. For the most part it’s always a constant solid yellow light, but I just plugged it in and tried to reset it and it was solid yellow then blinked blue one time, made some clicking noises and then it went off to no light at all then goes back to solid yellow light 5 minutes, makes a few more clicks then goes dark again. I’m waiting to see if it’s doing a long reset or something (read this somewhere) but again I’m wishing on a dream. Also, this isn’t the first time it’s happened. This has been slowly happening over a 2 week period so I’m not just coming to community forums without trying everything I could research.
waiting for solid yellow light but still no light at all

I was confused, first you said you unzipped it then you said you can’t unzip it.

You said you have a tablet. Does the tablet have an SD slot? If so you could unzip the file on the tablet and transfer the renamed .BIN to the SD card.


I have uploaded the demo_v2_4.9.5.36.bin file to Firefox Send. You can download it rather than the .Zip file. Remember to rename it.
It’s the same size as the .Zip, just over 8 Mb.


Hello again and thank you so much.

My laptop is still restoring (bad idea on my part) but I can’t wait to give that a try. I would rather do the non zip one (second option) but I do have a Samsung tablet that does have a SD card so I’ll use that as a back up.
Even if none of this ends up working for me I’d still like to say thank you :pray: so much for taking the time to help me out. It really means a lot and you’re a really special human being to even offer your time to help me out. Have a wonderful Sunday and I’ll post back with an update when the laptop is free.

Cheers :clinking_glasses:

No problem at all.
You can download the .BIN file to your tablet also.

1 Like

Well after many, many tries it actually worked. I’m not expecting it to last as it was acting up prior to this issue but it sure pays to be persistent. I’m not even sure which method worked as I tried them both so many times on both my laptop and Samsung tablet. I had solid yellow, flashing yellow with 1 blue flash, all flashing yellow to nothing lit up at all. The ready to connect prompt lady was stuttering. It was a mess!

Thank you from the bottom of my heart for taking the time to help me out. Right now I can’t afford a new Wyze cam as much as id love to buy a bunch. You saved me money I didn’t have. :pray:

enjoy your Sunday.

Great. Happy to hear you got it working.

1 Like