Android Audio Bug (2?)

(Possibly duplicate topic, was having some error with the forum, posted topic, but wasn’t showing up??)

Found minor bug that probably few would notice.

When listening to music through my BT headphones, then opening Wyze app, then selecting a device causes some weird audio as the app loads the live stream, presumably as the app requests access to the phones mic and speakers for audio playback and speaking. Music will continue to play after a short pause, but sounds as if you are listening to “hold music” while on a phone call.

That is all fine, but the problem is when you leave the livestream, the app maybe still has control (?) of the phone mic and speaker. I know this because scratching my finger across the BT mic plays the noise in the headphones, and I have seen some instances where the phone still thinks it is on a BT call (seen when trying to change the volume using the side buttons)

Closing the app using the app switcher fixes the mic and speaker and I can resume listening to music in normal quality.

Just a strange little quirk I noticed and am reporting. Can possibly provide further details or screenshots if requested.


Other info:

Phone - Google Pixel XL

Android 8.1.0

BT Headset - Jaybird X3

Similar issue here. Same phone and Android version. I noticed that the app uses the phone audio channel and not the media audio channel and when I connect my phone to bluetooth in my car, it acts like it’s in a call to my own phone number and it won’t release the connection and allow my car to connect to media audio so I can play music or audiobooks.

Same issue here. Google Pixel 2 on 8.1.0. App holds the bluetooth phone connection open and won’t allow me to open bluetooth audio connections (and, when I close the app, my phone tries to route audio through the phone channel to my car stereo).

The use of phone audio as the default audio out also probably explains why audio quality from the camera is so terrible and quiet.

I’m not so sure I would consider this a ‘minor bug’ - I’m really hoping this is fixed very soon! I received my Wyze Cam Pan camera this week and was super exited to get it setup. I noticed after just a few minutes that I no longer had any of the following: text notifications (sound or vibrate), ringtone on incoming calls (sound or vibrate), keyboard sounds, messaging sent sounds, etc. Unfortunately, I also noticed the next morning…NO ALARM SOUNDS when my morning alarm went off…complete silence and unfortunately late for work!!! I also experienced the issue of when connecting to my vehicle’s Bluetooth that my phone dialed itself and asked if I wanted to switch to hands-free mode. I spent a few days tinkering with every setting possible, including trying to reset all of my custom notification and ringtone sounds - with no success. In fact, I wasn’t even able to select any of them! Luckily, this morning it occurred to me that the Wyze Cam app must somehow be ‘in control’ of my phone/sound as it is ‘listening in’ so I killed the app from running in the background and viola, problem fixed…at least for the moment. However, this solution is not acceptable…If I forget to kill the app when I happen to not be actively using it, that means that I won’t receive critical notifications from my home alarm system, bank or critical phone calls. Please advise that there continues to be work to correct this bug in the app.

Phone: HTC U11 running Android 8.0

Wyze Cam Pan firmware version:

Wyze App Version: 1.3.162

Same issue. I’m discouraged that this was reported 3 months ago and still no response from Wyze.

Here in 2019

I have this same issue on my note9. However It’s not just bluetooth, but just my phone in general. If I don’t close the app it will stay in call mode. I missed 2 work alarms and a phone call. Please Wyze: Acknowledge that you’ve seen this thread and will address it. It’s a big problem.

We actually recently made changes that improved this for many people. We have another fix that we’re working on for the 2.1 update that will hopefully fully resolve this. If you’re still having trouble after that, please let us know!


Would be a perfect idea to stop using phone audio channel and instead use the media channel, like all (video player) apps do.

1 Like

Just got mine tonight! And having this issue. When is the 2.1 coming out? Im thinking of returning these if it isn’t fixed soon.

Phone galaxy s9
App 2.0.26

Same issue here… what gives? Anyone figure out a fix other than having to remember to shut down the app every time you use it?
I just got my camera today, and experienced this when getting into my car. I have the most recent firmware and app…
Anyone get this figured out?

Android app 2.1.17 I also loose Bluetooth audio when viewing the livestream - only way to regain audio from my phone via Bluetooth is to close the app

@WyzeGwendolyn Is the new update out yet? I have version 2.0.26 and this app is constantly messing with my phone’s sounds. I haven’t had a notification, alarm, or phone call in over a week. Even when I think I have closed out of the app, there’s still nothing. I tried looking in the play store for an update but it doesn’t say there is.

I’m on 2.2.17 Beta I dont know why you wouldn’t see the update as available

I’m having the same problem for months now. I had never thought it was caused by the Wyze App.

I’m using Android 8.0.0 on a Galaxy Note 8
With version 2.1.17

No, we don’t have the update released to the public yet. I’m going to send this link over to the dev team with a bug report. Thanks for letting us know!

@fizixtchr and @JeryRivera, the dev team has informed me that we have a fix for this that is working well internally. It should go with the next app update.


I’m on version 2.2.38 and it still treats the audio as if it’s “in-call”, which severely limits how loud it gets. This also still creates the Bluetooth issues others previously reported earlier this year and late last year in this thread.

Almost a year later, and this issue still persists in the app. I’m on the latest app and upgraded firmware on my Pixel 2 phone.

Thanks for the update! Could you please confirm the specific app and firmware version numbers you’re running?

Also having this issue, can’t hear audio on my BT Bose headphones, very irritating that I can’t hear the audio on it and need to force quit in order to disconnect the “call”.

Wyze (Beta program)