Android app: error (code 09) video player error: support sends me to forum

I have been using Wyze products for a few years now.
When I started with my Motorola G Stylus I was able to playback movies after motion detection. I broke the glass of my phone after dropping and moved on to a new phone: Moto G Stylus 5G (2022) with Android 12.
I could not get the event movies to play, live stream works.
Opened a ticket & submitted diagnostic log and basically never heard back.
In the mean time my phone has been upgraded to Android 13 and no change.

Error (code 09): Video Player Error. Please try again later. If this happens again, please submit a developer log through Wyze Support in Settings.

A couple of weeks ago I bought a new phone for my wife: basically same phone as mine but 2023 model (1 year younger) and the wyze app works completely without any issues! Her phone plays back the events instantly and without any issues.

So I decided to open another ticket & submit diagnostic log.

This was the return email from support:

Nov 25, 2023, 12:21 PM PST

Hi Danny,
Thanks for contacting the Wyze Wizards team. My name is Jake and I'm sorry to hear that you are having trouble with the connectivity of your device. No worries I'll do my best so we sort things out together.
Here are some steps I would like you to try:
Try rebooting the router.
Do a factory reset and set the device up as new.
Cam v3, Cam Pan v2: Remove the SD card if there is one inserted. Hold down the setup button until the status light turns solid red. Once the status light begins flashing red, then you may attempt to set it up again
Ensure that your  Wyze app and camera firmware are up to date.
Do a power cycle of the camera by unplugging it for about 30 seconds and plugging it back in.
Make sure location permissions are turned on for Wyze.
If using iOS, ensure local network permissions are turned on in the privacy settings.
Make sure that you have entered their SSID (WiFi name) correctly. It is case-sensitive.
There should be no space before or after the SSID.
The SSID should automatically populate if the customer is connected to WiFi. If it does not auto-populate, it can indicate the phone/tablet is used for setting up is not connected to WiFi.
Check to make sure they are entering the WiFi password correctly.
Ensure that your phone/tablet being used for setup is connected to a 2.4GHz WiFi network.
Wyze devices are not compatible with 5GHz WiFi networks.
Make sure the camera and phone/tablet are close to the router for setup (within 6-10 feet).
Try forgetting the WiFi network and rejoining the network. Then retry the setup.
To set up your Wyze Cam v3:
In the Wyze app, tap on the Home tab, then tap the + plus sign on the top left.
Tap Add Device.
Tap Cameras > Wyze Cam v3 > Begin setup.
With your camera plugged into an outlet, tap Next in the app.
Pull the base from your camera and single-press SETUP under the camera until it says “ready to connect”.
In the app, check the box next to I heard, “Ready to connect”.
Tap Next.
Select your 2.4 GHz Wi-Fi network and enter your network password. Tap Next.
Tap the icon in the password field to display the password to ensure it was entered correctly.
Scan the QR code on the Wyze app.
Hold your camera up to your phone screen with the QR code displaying. It will say “QR code scanned, please wait” then “Setup completed”.
In the app, check the box next to I heard, “QR code scanned”.
Tap Next. You’re set up, it’s time to name your device.
Name your Wyze Cam v3 using the text field, or by choosing a suggestion.
Tap Finish when done.
You may have a prompt for a free trial of Cam Plus. Tap Continue.
On the Things to Try page, select Create or edit a device group to organize your Wyze devices into new or existing groups, or select Share this device to give family and friends access to your new Wyze device.
Tap Skip to do this later.
You’re all set. Enjoy your new Wyze device!
If this has not resolved your issue, I do apologize but you’ve come to the right place. You may be eligible for a Wyze Gift Card for the amount of your product or a replacement to get a new one camera. We will be happy to take a look and see what options are available for you.

That is an impressive list but the fact my live stream works, but only not the event playback makes me believe that it just my phone, I also didn’t mention that my old (retired) phone and the new phone of my wife work without a hitch.
So it is not the “environment”

So I wrote back:

I forgot to give some important information.
My phone is a Moto G Stylus 5G (2022) currently running Android 13 and has had this problem since the beginning, including while it was still running Android 12.
I have opened a ticket about this before.

Now for the ticker:
My old (retired) android phone Moto G Stylus (don’t know the year) running Android 11
and my wife’s Moto G Stylus 5G (2023 so one year younger than mine)
both have no problems with playing events.

So we can forget about all the other stuff, Sd cards, firmware, router etc etc.
I currently have 3 camera’s installed, flawless with my old & wife’s phone, just MY phone giving me the error.

It is just MY PHONE Moto G Stylus 5G (2022) Android 13 that has this problem.

Hopefully this can give you some direction/suggestions and suggest useful tips on how to debug the issue further.
My phone is standard: not rooted, running standard Android OS

Looking forward to hearing from you

The answer they returned has a whole lot of information but without any real hint/clues/requests imo:

Thank you for getting back to us.
I wanted to extend my heartfelt gratitude for the additional information you provided regarding the connectivity of the camera. Your input is immensely valuable to us and plays a crucial role in assisting not only yourself but also other customers who might encounter similar concerns.
Your contribution greatly aids our efforts in resolving issues effectively and continuously improving our products and services. We deeply appreciate your willingness to share your experience and insights, as it contributes significantly to the Wyze community.
Rest assured, we take note of your concern and will escalate it to our product development team for further review. Your feedback serves as a vital source of inspiration for us to explore enhancements and address any potential areas for improvement.
Additionally, I encourage you to explore our forums where you can engage with other users, share your experiences, and suggest further ideas or improvements. Your active participation in our community forums can create a positive impact and help shape the future of our products.
Our product team is always looking for ways to improve our current products and to know what our fans would like to see next. I'll be sure to pass your feedback along to the team, but the best way to get ideas on our radar is through our official Wishlist.
The Wishlist is a part of our community forums where users may post ideas or suggestions that they have for products, services, or features. Once posted to the Wishlist, the request may be voted on by other users. This allows voices like yours to be better heard by us!
Our community and product teams go through these requests regularly. While we cannot promise that every request is a project we will take on, having that line to our users’ voices helps lead to great changes.
Please feel free to add your voice to the conversation here:
Thank you once again for your invaluable input. Should you have any more suggestions, thoughts, or experiences to share, please feel free to join our forums or reach out to us directly. We greatly value your engagement and look forward to hearing more from you.
Warm regards,

My return answer:


We thank you for the extra information.
We don’t know what is wrong.
We can not give any more advice on this.
Maybe you will find some solution on the forum.

That’s it ?

Did I understand that correctly?

and the final answer from official support @ wyze:

Yes, some of the information you can find it on the forum since some of the customers shares their experience, and things they have done to fix it but from the information you shared, you posted that as well on the forum so our developer would notice and will get some idea on how to fix bugs.
Thank you for being part of Wyze and stay safe always!

All the best,

So support doesn’t seem to be willing to dig deeper in my situation:
2 phones working, 1 doesn’t
Pointing to the forum to see “what others did to fix it”

This is the first time I have ever gotten that feedback from official support.
How about the developers who are on this forum and who might take a closer look?!
Has this happened before ? is it useful ?

Does anyone have a useful solution for the Error (code 09) situation ?
I stopped the app, deleted all stored information, deleted the app, rebooted phone,
Did a fresh install: still the same.

I am bummed and since there are a lot of coyotes recently on my property that triggered the movement condition, I really want to be able to see what is going on.

Any help/suggestions ?

Have you enabled the Hardware Decoder in the Account> App Settings?

Thank you for your feedback.
Yes, it is on in my app:

Should I try and turn it off and see if it makes a difference ?

You might. But I’m not hopeful.

I actually got that error today on my Android Moto G Stylus 5G 2023 Android 13, but it is rare. For me, a phone restart does the trick. I would suspect that there is some issue with that 2022 version Moto hardware or an obscure Android setting that is causing the problem.

1 Like

Agreed, I found several other threads with a similar issue and with different camera models where it streams fine on their other phones, just not one of them, exactly like this. It seems there is some Android setting that interferes with it. I didn’t see anyone finding a solution.

I would try clearing the cache and app data from the Wyze app and trying again.

I am reading that this problem is sometimes caused by storage space limitations. I don’t think that’s the case here, but didn’t want to leave anything out.

I’m not suggesting this last one, but I read online that some people have resolved similar issues with the nuclear option…ie: factory reset the phone and start from scratch with settings, etc.

It is almost definitely something with the phone since everything is working fine with your account on other phones, just not this one phone. So it seems like everything is working fine on Wyze’s end since you can access everything correctly from other phones. If it’s not working on just that phone, I’d say the problem is with the phone somehow, likely a setting, but maybe something else.

Maybe it’s something weird like a portion of your phone’s video codecs are corrupted. This would allow it to work normally in general, but screw up with particular types of video streams like this.

It could even be another app. I had something similar where it turned out that one app was screwing up things with a different app. I only discovered the cause by systematically deleting one app at a time until the other started working, then reinstalled that other app and it stopped working again, when I then removed it again, it was fixed again, so some apps sometimes cause problems with other ones…strangely…


One event that was recorded this morning gave the Error (code 09) on all 3 phones.
I think for some reason the event was not uploaded correctly to the cloud and can not be replayed correctly.

Later events have no problems on the 2 phones, but still on mine.
I also did a complete poweroff and startup on my 2022 phone.
Still the same error/condition :frowning:

That is a bummer

Tried that already (described in one of my previous postings), no difference.

Good suggestion !
I just checked: phone has 256GB plus a 256GB SD card

I don’t think that is the case either.

That could be it.
I would have imagined that Wyze support could/would see more with the diagnostic log that I sent with the ticket that we can see and they would be interested in identifying the issue so they can share it in the future with others who encounter this problem. Just like they said in one of their automated replies.

Oh well…