Alexa Show not working

I have 2 out of 7 that do not work with Alexa (on Fire 8 HD tablet). I made a post here this weekend (didn’t see this one) regarding it not working, and the causing my 2 cameras to keep trying to upload immense amounts of data. Unplugging the cams stopped the data upload issue, but they still do not connect to Alexa; I submitted a report and log from the app this weekend, but do not have a ticket # yet. I’m happy to provide more info as necessary to the Wyze team, just let me know.

Tonight, I received a firmware update for my Wyzecam Pan to version 4.10.3.40.
The camera is still does not respond to the Echo Show even after unplugging and repowering the camera.
For a while, I hoped there was a fix. :disappointed:

As of today, March 5, 2019, echo show and the wyze cameras still do not play together. A WORKING combination seems to be the exception and not the rule. I don’t want to plug and unplug, disable and enable the skill, I just want the thing to work!! Amazon needs to stop advertising that these products are compatible. They are not. It is deceptive and wyze, you are hurting your brand.

3 Likes

My 2 V2’s still do not work on my Echo Spot.

I’ve enabled/disabled the skill multiple times, flashed all cams to newest firmware, rebooted my network, rebooted the Echo Spot. Nothing has worked.

I have noticed though when I try to view the camera via Echo Spot, my router shows traffic to that camera in the 70KB-130KB range. I see the Wyze screen on the spot, but then I get the error from the Echo Spot that something went wrong. This traffic on the camera that I tried to view still shows the activity that I mentioned unless I unplug/plug the camera to reboot.

So something is happening but obviously there is a timeout or hiccup also occurring, but the stream is still happening behind the scenes.

Trying to be patient :slight_smile:

me too! My 2 V2 never worked with Echo Spot since I bought them. it is getting really annoying. This brand should be excluded from Alexa Compatible device. it is misleading! :frowning:

1 Like

I have the issue where the devices show up (Wyze Camera) on Alexa App. The Wyze skill is installed, and the devices are recognized when searched for by Alexa. When I say “Alexa Show [Camera Name]” it attempts to establish the feed but ultimately times out after a while and alexa states the camera is not responding. The phone app works seemlessly (I can see all cameras). I have tried both my Fire TV, and my Fire TV Stick… Same problem on each. I have the latest camera firmware, have restarted each camera (waiting 30 seconds between unplugging, and plugging in to make sure memory is entirely wiped out), and then re-installing the devices with Alexa. Same issue.

This is the response I have received back from Wyze Support (See below)… Piggy backing this communication from the Amazon Forum back into the Wyze Forum

SUPPORT EMAIL:

Thanks for following up with us and sorry to hear the previous options didn’t fix your issue.

At this time the Alexa problem is a known issue and we are actively working to fix the problem in conjunction with Amazon. We ask that you reach out to their customer service and see if they can offer you any additional help, that would be outside of our troubleshooting abilities right now.

Amazon Support: https://www.amazon.com/gp/help/customer/display.html/ref=hp_bc_nav?ie=UTF8&nodeId=200127470

I also understand this is not the answer you are looking for and we are experiencing other users with the same issue.

We hope to have a solution soon and appreciate you being a customer

Thank you for your patience!!

1 Like

sounds like finger pointing to me…yikes… :frowning:

My Wyze Pan now responds to Echo Show and the image is displayed. :blush:

My cameras are finally working with my echo show. I am cautiously optimistic. I recently rebooted my router but not sure if this did the trick since I had tried this before. Apparently a clean reboot can solve problems by getting rid of any residual settings that may be causing problems. Note that I only have two cameras.

My started working this morning or maybe last light. I had to reboot all the cams as they couldn’t connect to the app. I checked with my fire TV this morning and the cameras popped right on up.

Guess I’m going to edit my post on Amazon and I hope I’m not being premature :wink:

Great job by the Wyze team and Amazon for solving this (I hope :pray:)

All my cams are now working after a power cycle (Unplug power/plug in)

1 Like

Ditto here!

Went out of town for a couple of days and when I came back, the cams were working. I did absolutely nothing to them, so I assume Wyze or Amazon fixed the issue. Thank you to whomever it was that implemented the fix.

Now if we could just ditch the 10 minute timeout… :slight_smile:

1 Like

The timeout is actually only 5 minutes. You may want to hop over and vote for this topic:

No, that doesn’t seem to have anything to do with what I’m talking about. On the Echo Show, the camera only displays for about ten minutes, then it (the echo show) goes back to its home page and you have to ask it to show you the camera again. I think this is a shortcoming of the echo, not the wyze cam.

My bad. I spaced on which thread I was on. Had just got done answering a bunch of stuff about he motion event timeout. :zipper_mouth_face:

I just went thru an entire week where I wasn’t able to mute my home receiver using my voice. I highly suspect that at least some, if not “nearly all”, of the issues connecting our Wyze cams to Alexa Show/Spot are due to Amazon software. Oftentimes, these issues will “magically” fix themselves.

Late to the party, but I have some of the same issues with my Echo Show 5 and Fire Sticks. I can ask to see any of my 6 Wyze cams and they will show fine for a few seconds, then start buffering or getting pixelated, then close. Occasionally I can view a camera for a few minutes without problems, but that is rare. When I view cameras on my Fire HD tablet or phone (using the Wyze app on both devices) the live view works perfectly.

Same issue. My Wyze Cam has worked with my Echo Shows in the past but now when I ask to show my camera the Echo will display it but buffering starts. It will connect for a few seconds and then buffer some more, finally it will close. The Wyze cam works fine via my phone and tablet. My EZViz cameras work fine with my Echo Shows.