Alexa Routine -Device not supported-


I was able to link my Wyze account with Alexa. But when I follow the posted instructions on creating a routine it fails with Device not supported

From Alexa app
More->Routines-> Add Routine->Add name. Works up to here.
Adding “When this happens” from the app. Select Smart Home icon. Select my camera. Fails

This device is not currently supported

Is this because I have not registered for cam plus, or is it a locale issue (Canada)

Currently the only alexa routine triggers for the cameras are when a person is detected. This is not available in Canada unless you log into your account and change your location.

You might be able to do it with either the Wyze RTSP firmware or the Dafang Hack and an Alexa skill called Monocule and a Monocule account.

No promises, but it isn’t too hard to set up if you enjoy minor tinkering, and Monocule is free right now, since it is in beta.

So if I subscribe to the Cam Plus it would work or still not work because I am in Canada.? Wyze site seems to allude that Alexa skills work in North America. I am pretty sure that person detection (ie Cam Plus) is available to Canada?

I’m in Canada and cam plus and person detection works for me. The wyze sense sensors work fine as triggers for Alexa routines as well.

Using the camera’s “person detection” triggers for alexa routines initially did not work for me until I changed my location of my account from a PC web browser.

So to get a CAMERA in Canada to trigger an alexa routine you need to have:

  1. cam plus OR person detection enabled
  2. change the location on the account to USA
  3. Tell alexa to discover devices

Note: The cameras right now can ONLY trigger a routine if a PERSON is detected. All other motion: cars, animals etc… will not set off a routine.

The wyze sense motion and contact sensors are much more flexible at triggering routines.

1 Like

Thanks for the reply. No luck with your suggestions. I think my issue is when it reports that device is not supported is probably referencing my Alexa device not the Wyze camera. I have a dot, and I don’t see the dot on the list of supported Alexa devices.

That shouldn’t be the issue. The only alexa devices I have are a dot and a fire stick 4k and the announcements work on the dot. If you havent already done so you can try unlinking and rethinking the wyze skill in alexa to see if that helps.

No luck, went into the pc software, changed the location of the device (dot) and the locale of the software to the US. Unlinked the skill, re-added, repowered the devices. Same error.

I did try another routine where I used something else for “When this happens” and tried to add the camera as the "add action and the same error, so that tells me that the error is referring to the Wyze camera not the Alexa dot.

Only other thing that I think it could be is when I go into services it shows my active subscriptions as Person detection (pilot)

I spent the last few weeks with Wyze support debugging this issue and I even said to them is this skill good for Canada and they said YES. They even told me to Contact Amazon because it was a problem with my account.

It is sad Wyze support has no idea what the limitations of their own skills are in Amazon! Amazon said it was a Wyze problem.

I made the changes recommended in the video and it worked! The options are a little different now because the Amazon website has changed.

It is definitely a problem in Canada. I have placed a ticket in November 2020 with Wyze and another one recently, but I don’t think enough people are reporting the issue for them to spend any time on fixing it for Canadians :frowning:
If you have the same issue - please place a ticket with them.