Alexa intermittent connection problems

I recently installed the WyzeCam Pan camera. I’ve got some issues with it:

  1. On occasion, when I ask Alexa to show the camera, she will respond with "Hmmm, the camera is not responding" even though I can see the live stream from my Android app. If I ask later, she may show it correctly.
  2. The Android app seems to be very slow in performance. At times, it may appear to be hung. But, waiting for several seconds (30-45?), it usually responds.
1 Like

I find it hard to believe that I’m the only user with the ‘camera is not responding’ problem.


1 Like

I was having that sort of issue, I added a set of WIFI Extenders to my LAN and all issues evaporated instantly… What is the WIFI level on the failing camera? SETTINGS>DEVICE INFO> will show you.

Thanks for the reply. I already using an Eero mesh network. The Device info states that the signal is 100%. As I stated, the problem is intermittent which leads me to believe that the camera is busy doing some other task.

This happens 90% of the time for me too!! Very frustrating… all other devices work great and the camera is in same room as router!! So is Alexa… 600megs a second internet … it is the camera / alexa communication problem… but what is the fix? I keep unplugging and plugging it back up… it works for a day… back to your exact Alexa error… and same here… can access it via app just fine

1 Like

Anybody have a fix for this? I have a fire Tablet HD that I have in Show Mode, that I bought specifically to work with my Wyze Cam, well… it worked the very first time and after that it’s been nothing but “hmmm I’m having a problem connecting to your camera”…
I’ve unenabled, re enabled the skill, restarted the tablet, restarted the camera, done both, unenabled and restarted the tablet and then re enabled, everything I could possibly do on my end and nothing. is working now going on two days…

I have the same problem with Alexa echo show 2, some one fix the problem?

1 Like

Same issue here, but two of my 4 Wyze cameras work, but even those two working it takes a long time to load on the Fire Tablet. The other 2 I get the “Hmmm, the camera is not responding” message always. Tried removing and reloading the Alexa skill, tried removing the cameras in Alexa and adding them back on. Any other suggestions? This happens in two Fire Tablets. I have excellent wifi coverage where they are located. All cameras are at the same and latest firmware level as of today.

After latest firmware update nothing works in Alexa.

I’ve been using an Alexa Spot since November. The connections to my Spot work approx 80% of the time, whereas the connections to my app work approx 95%. The connections to the Spot seem to be getting more reliable…initially they seemed to work only 50%.

NOTE: I have not done the latest firmware update.

Been trying to poll the community about this and seems at best we have a 50/50 chance of a successful Alexa integration.

Really don’t understand how this company can even market this as a feature.
At least until it’s stable be upfront its in development and don’t advertise it.

I bought these cameras for the Alexa integration, which was advertised and it’s not delivering…

Just to give an update. It is back working. Strange that now 3 out of 4 work with Alexa. I can’t figure out why only 1 doesn’t load now. Nothing different in terms of configuration. The only one that doesn’t work is actually inside the house, the others are either in my garage, front of the garage (outside), and backyard (only one that is a Pan Cam), also outside.

I’m having same issue with Wyze v2 camera. Echo Show was working fine with Alexa showing the camera feed. I went out for a few hours and now Alexa can’t find the camera, I spent over 2 hours with Wyze and Amazon tech support to no avail. I bought the Echo Show and Wyze cam because they supposedly supported each other, I’m probably returning the Wyze cam and Echo Show to Amazon for a refund!

Alexa… Hmm the camera is not responding… all my cams. Some right next to router…

I am also experiencing the same issue with all my Wyze cameras (8 of them) and all my Alexa shows and fire tv’s (6 of them ) . Was working fine. It’s either a Wyze thing or Alexa thing. Thinking Wyze. All
Cameras work fine in Wyze app and in my tiny cams app on Android.

Ring doorbell camera is working fine using Alexa and Fire TV or echo show. Just not any of the Wyze cameras. I tried disabling the Wyze skill in the Alexa app and re-enabling it. Didn’t fix the issue.

I am having same issue with 1 of 2 wyze outdoor camera. Its really embarrassing for me and for wyze when i go to show off to friends and family the camera when it doesnt work.

Yeah, I had the exact same problem except I’m using an iPhone with an echo show

I got to the point where I was using a Wyze plug so I wouldn’t have to restart the camera by unplugging it; I could just simply turn the plug off in the Wyze app but still it’s annoying nonetheless