Air Purifier Firmware Stuck on

Not getting updated The newest air purifier beta version is I have two air purifiers, one I got at launch and one I setup yesterday, but the one I got yesterday will not let me install firmware version because it insists version is the newest. I need both air purifiers to be on the same firmware. Thanks.

Welcome @heatthefurniss

The Wyze Air Purifier current production release is:


Found at this location under Home:

Release Notes & Firmware – Wyze

The appears to be a Beta Release of the Firmware as indicated here:

Air Purifier Firmware Beta Test 1/11/2023 - Beta - Wyze Forum

I know what both firmwares are, BTW. And yes, I am on the beta firmware on the air purifier I got at launch, but the one I installed yesterday does not have the option to update to the beta firmware.

Go to About, Beta Program, and then edit. Make sure the Air Purifier is selected. Sometimes the selection may get removed.

If it is selected, I would uncheck it, click on save, then select it again and save that.

I have already done that more than once

Have you tried removing the power from the Air Purifier, wait for about 30 seconds, then plug back in? In essence, cycling the power and connection.

I have done both, and I have removed the one that has the beta firmware on it from my account for a while and then added it back to my account. The only thing I can think of is that it still thinks I am on the beta firmware because one of my devices is on beta firmware. but it should know that customers could have more than one device.

@R.Good , @carverofchoice , @SlabSlayer , @IEatBeans

Do you have any other suggestions?

Support just emailed me and said, “I understand, but for now, we have no option for you to update your other Air Purifier to We are so sorry for the inconvenience.”

If a problem exists where only one Air Purifier can apply beta firmware, try deleting the problem Air Purifier from the device list via Wyze app, unplug both Air Purifiers, leave the beta firmware device unplugged, clear app cache and force close the Wyze app, plug the problem Air Purifier in, do a reset on the problem Air Purifier, re-add the problem Air Purifier to the Wyze app and retry beta firmware load via Wyze app Home > your Air Purifier icon > Settings (gear icon) > Device Info > Firmware Version. If it works, just plug the other beta device back in.

If that doesn’t work, delete the problem device from the Wyze app, setup a new Wyze account for the problem device only, join beta using this new account, reset the Air Purifier and add it to the new account, add Air Purifier to the beta device list via app, retry firmware update. If it works, delete Air Purifier from new account, delete new account, readd Air Purifier to old/existing account.


should i remove both air purifyers from my account

NO. Just remove the one that won’t load beta.


I have done that yesterday besides the new account, but I will try again using your steps when I get back home.


Sorry, I don’t have the Air Purifier so I’m not going to be any help.


Same here :cry:

1 Like

That happened to me in the past. I left it for a few days, checked again and it worked.

If you have another phone or tablet, I would try for that as well and see if it makes any difference.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.