Air purifier Firmware Beta Test 11/14/2023


What’s New:

  • Implemented a new Wi-Fi module

Took about 4 minutes to update, but it completed and it’s running well. I didn’t previously experience any WiFi issues, but I’ll keep an eye out for anything unusual with this build.


@WyzeJasonJ @WyzeAndy

Updating now. Have 2, but updating one at a time.

After 10 minutes, I received the Oops something went wrong message. I then restarted the device, it connected to the network and trying again.

Second try failed as well:

Note: At the 9 minute mark, the WiFi symbol on the AP started to flash, it then connected again just to give the failure screen.

Log Submitted: 1232653
Device Used: Pixel 8
Android App Version: 2.47.0 (b372)
Current FW:

Failure screen

Will try restarting the app now - Did not fix it

Decided to use the Firmware update page, kicked off the update, after 10 minutes it was still running, decided to back out and go to the AP itself again and kicked off the upgrade from there, even though the Firmware update page showed updating. Well, it was successful this time. have no reason as to why. took about 6 minutes when it did work.

Now on to the next one.

Firmware install had no issue on this AP. Different experiences between the two.


I tried to first update the air filter via the mass update page. I checked back on the device in the app directly and found that it failed. I was offered the chance to upgrade again.

I went into the device update page and started the process. After about 5 or 6 minutes it failed. I tried again right away and it successfully completed in 5 minutes.


Took me 4 tries.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.