Yellow Light - On - Ready to Connect

I have two V2 cameras. I plug into the adapter, the yellow light comes on. That’s good news.
However, when I press down on the connect piece there is no audio - no ‘ready to connect’.

What’s to do?
If there is the imperative to do a factory reset how would one do that?

Let me know how to advance with the needed audio ‘ready to connect’

I am having a similar problem. I had set up my camera and linked it to the app. I had the flashing light, the voice command, everything went as planned. I was then instructed that I needed to download an updated version of the firmware for my camera. It also said not to power off the camera during this download.
At sometime during the update, my connection was lost and the download failed. So I tried to reset the camera and start the process all over again. However, the little yellow light on the camera reained solid. It never flashed or blinked, no matter how many times I hit the setup button. I deleted the camera from the app to see if I could add it to the app and start over from there, but that did not work. No matter what I do the yellow light remains solid. The camera makes some clicking noises every now and then but i can’t get a voice prompt or anything to do what it is suppose to. I can’t get the new firmware to download because there are no devices associated with my app since I deleted it.
Can I reset the camera, or get the firmware loaded onto the camera a different way? It was all working fone until I tried to update the firmware. Now I can’t get it to work at all. Any help would be greatly appreciated. Thanks for your time