WyzeCam v2 Connection Failure

I’ve followed all instructions to the letter, yet can’t get the WzyeCam v2 connected to my network. It consistently says it can’t connect to the local network. My particulars are as flows:

Wyze Cam v2
Firmware Upgraded to v
WyzeCam Android App v 1.2.76

Phone - HTC One M8
Android OS v 6.0 Marshmallow

Router – Netgear Nighthawk R6700v2
Firmware v

The units readily scan the code images and then say unable to connect to local network. I’ve installed, uninstalled, and reinstalled the app five times to no avail. I’ve restarted the router an equal number. I’ve also manually authorized the device’s MAC address without success. This is the first device that has ever failed to connect to this router. One unit connects through another phone, but not my primary, listed above. Granted, it’s an phone but within the spec for the camera/app combo and it has zero other issues.

What can I do to connect the cameras through my phone?

Is the router providing a 2.4GHz wifi signal (WyzeCam will not work on 5GHz wifi) and is it WPA/WPA2 security (WyzeCam will not work with WEP)?

Either of those would prevent the camera from connecting.

I turned off the 5GHz radio. So that isn’t the problem. I’m using WPA2 PSK.


I’m actually having the same issue.


Kind of sucks we have to manually enter the SSID for the WiFi. I’ve honestly never had luck connecting a device by entering that manually. You’d think it’d be like other cameras and just recognize the WiFi the phone is connected to and use that for the QR Code (at least, my Arlo camera was super easy to set up like that).


The app does prefill the current wifi SSID and password that the phone is connected to, at least on iOS.

I bought this mostly because it was billed as easy setup, feature rich and affordable. Some of the most desirable features aren’t working as sold, and neither is it consistently easy to setup and use. I’d hate for it to turn out to just be cheap.

Edit, between when I started this and posted it, I see you said that you already disabled 5GHz radios.

My experience with the Android 1.2.76 app was that it did not fill in the SSID or password. The 1.3.107 does.

I recommend using the Beta Android app 1.3.107. It has some new bugs, but IMO they are minor compared to the issues in the Android 1.2.76 app.

I am not sure that will solve the initial config or not.

With my v1 cameras I had to set up on a router with only 2.4 GHz radio enabled. After the setup everything worked with both 2.4GHz and 5GHz radios enabled, both using the same SSID.

If you have admin access to the Nighthawk, you could try turning off the 5GHz radios and see if it makes any difference with the current app.


If it connects, with the 2.4GHz radio, then turn the 5GHz radios back on and power cycle the camera to verify that it is able to connect.


Do you have any ports blocked on the router?

OK. So what about android 6.0 as mentioned above?

Maybe I will try the setup from my iPad and see if that works. It will be annoying if it was the fault of the currently released Android version of the app.

I’d like to try the 1.3.107. Is there a published procedure to install and roll it back if necessary?

Poop. iPad ran into the same issues (even though it did autofill the field).


Going to try turning off 5GHz signal temporarily.

It did finally work for me after disabling 5GHz and using my iPad.


Though since this worked for me, I didn’t try using my Android again with 5GHz disabled, so that may have worked too for all I know.

You can probably just grab this and install it over your current app: Wyze - Make Your Home Smarter 1.3.107 (arm + arm-v7a) (nodpi) (Android 4.1+) APK Download by Wyze Labs Inc. - APKMirror


Then if you want to “roll back”, just uninstall it and re-download from the Play Store.

Thanks. But prob not tonight. My wife is on the firestick which needs 5MHz to work well.

There is a topic on the Beta program. This post in that thread says you can uninstall the Beta and reinstall the non-beta. My guess is that you won’t want to go back.




You should be able to update the Android app with 5Ghz enabled, and be able to maintain a happy life. Then you can try changing one thing at a time. If I understand, you already tried 1.2.76 with only 2.4Ghz and that didn’t work.

So now try 1.3.107 with 2.4GHz and 5 GHz radios on and see if you can get the camera to connect. That would be a useful data point.

I have the same problem, and nothing I have done will let me set it up. It is still saying “local connection not found” and I did everything you did. This is very frustrating and I’m ready to send this cam back.

Did yoy=u get it to work finally?