Wyze cam pan wifi connection


Massively frustrated at the moment. Hope someone can help out.

Wyze cam pan won’t connect to wifi after scanning the code. Error is “cannot find specified network name”.

Yes, I checked:

  • 2.4 Ghz network
  • No special chars or spaces
  • Pwd is correct
  • My apple device is connected to the wifi
  • No firewall or mac filter on my router
  • No other rules on my router
  • Restarted wyze app, camera and router
  • Did factory reset on camera
  • Tried setup from another mobile device
  • Tried WPA-psk
  • Tried WPA2-psk
  • Wifi channel set to auto
  • Tried wifi 802.11 b/g/n mixed
  • Tried wifi 802.11 n only
  • Resets done between different settings
  • All this took me almost a day
  • Camera LEDs and voice prompts work as expected
  • Camera is brand new
  • Plastic tape taken off lens
  • Googled my arse off. Most sites just say check SSID name and password
  • Watched youTube vids
  • Searched the forum

I’m out of ideas

This is hugely disappointing.

Anyone with ideas please?


Is this your only WYZE camera or do you have others that connect correctly?
Have you contacted WYZE support?

What make/model of router? Is it a dual-band router?

I know you said “2.4 GHz network”, but many routers these days are dual-band.
And use the same SSID for both the 2.4 GHz radio and the 5 GHz radio.
If your “apple device is connected to the wifi”, it will generally choose the 5 GHz radio.
This is a common problem with Wyze setup. The smartphone connects to WiFi network named, say “myWiFi”. User thinks it’s connected to the 2.4 GHz network named “myWiFi”. But if it connects to the 5 GHz radio, the Wyze cam can have difficulties.

If your router happens to be a dual-band model, one approach is to (temporarily) turn off its 5 GHz radio. That forces the smartphone to connect to the 2.4 GHz radio. Another solution is to (temporarily) change the SSID of the 5 GHz radio to something else.

If your router is a single-band 2.4 GHz device, then it sounds like the Wyzecam is problematic.

I have a dual band TP-Link router with my phone connected to 5.0 Ghz. My cameras seem to be able to connect to the 2.4 Ghz band using the same SSID. That may be the exeption to the rule though. :slightly_smiling_face:

There seems to be a lot of randomness involved. When you first set up your cameras, are you 100% certain that the phone was connected to the 5 GHz band? With iPhones, it’s nigh impossible to tell which band they are associated with (assuming both 2.4 and 5 GHz radios have the same SSID). Some people have reported success with cross-band operation. I had problems early on, which led me to try changing the name of the 5 GHz radio to eliminate that variable.

These days, I have a completely independent 2.4GHz network serving the cameras (and only the cameras). It has a unique name, and is isolated from my primary network. If the cameras get up to no good, they can’t compromise the rest of my network.

With Android it’s easy to tell but the phone can flip from one band to the other without indication. That may have been the case.
This should be a separate conversation.
Probably shouldn’t dilute the OP any more. :slight_smile:

Hi there,

Thank you for the response.

This is my first and only wyze cam.

I mailed the support mailbox but received a response that the mailbox is not monitored anymore. I’m trying to find what other means there are of contacting wyze.



Thank you. I am 100% sure though there is only 2.4 available.

I set up the router myself when I moved into the house. I don’t use default settings or SSID.

I switched off the 5 ghz radio and made available only 2.4 Ghz SSID. I am really 100% sure the camera is not trying to connect to a 5 Ghz network and only 2.4 Ghz is available.

I logged into the admin interface of the router to confirm that is still the case and on the router body, there are LED indicators - the 2,4 LED is lit and the 5,0 LED is off.

You asked what router I have, it’s the D-link Dir-825.

Thanks again

Hello again all,

Maybe one thing I haven’t tried yet: would it be worthwhile to try and re-flash the firmware?

Not sure if it’s possible that the device I have has maybe left the factory a long time ago and eventually made it into my hands (I’m not based in the USA). So when I downloaded the Wyze app over the weekend, I imagine it would be the latest version app. I don’t know about the device firmware though…

Would it be worth a try or not really?

I’m actually having the same issue… started a few days ago and I’m an avid user with quite a few cameras. We are tech savvy and tried everything. My last one that did this had to be replaced but I’ve had several pans do similar over the past year, normally it’s an easy unplug and plug back in and a rarity to have to reset it. Mine is currently unable to be reset and just frozen yellow. I’m not 100% positive but I believe this is the replacement I received when my other pan up and died. I really count on this one as it guards our pool from an indoor sun porch and no reason for it to be acting up since it’s inside, hopefully you can get a resolution and please do feel free to share.


Good luck to you. I’ll share for sure if I do find a solution.

Someone asked: I have now also logged a ticket with Wyze.


1 Like

Sounds like you’ve done all the right stuff (disabled the 5GHz radio, reset the camera, offered incantations to the gods of cyberspace, etc). The next logical step is to open a ticket with Wyze, and I see that you’ve already done that.

While waiting for them to reply, there’s no harm in refreshing the firmware. It’s possible that what’s in the camera has become faulty. I once corrected a malfunctioning camera with a refresh.

Good luck!


I opened a ticket with Wyze, Unfortunately, their response consisted of a link to the default support page which I had already gone through before logging the ticket and then also they sent me a recommendation to ensure I connected to 2.4 Ghz and typed the password correctly - so nothing useful.

I explained I did all of that already and asked they look into more advanced troubleshooting.

Hopefully they come back with something useful.

Failing that, I’ll try the firmware as well. I also saw there was new firmware released yesterday and a new mobile app released today.

Should I manage to resolve it, will post here.


I just noticed that the gods of cyberspace auto-miscorrected my typing. I suggested that you reflash the firmware. Auto-correct changed it to refresh. And I didn’t notice. Doh!

I suppose one could ‘refresh’ the firmware, perhaps with a shot of Fabreze™. But I don’t think it would make any difference.

1 Like

Thank you - yeah I understood that meant flash :wink:

Have not done it yet though - trying to see what the Wyze Wizard from support comes up with other than “check your password”.

Also try turning off mobile data on your phone temporarily. That can be a killer.

Camera is now working.

Manual firmware flash made the difference.

1 Like

Thanks for letting us know.
Always helpful to learn what ‘fixes’ work. (And what don’t…)