Wyze Worst home monitoring system

Before I start my rant, I want to tell you that I have almost “all” Wyze products that I can install in my house. I loved their products till issue started with the home monitoring
My nightmare started when I was just browsing the wyze app checking status and realized that my wyze hub is telling me that there is no internet connectivity to the hub. I checked the network and it was working. Still I thought of connecting my hub to another wireless router with a different network. To my surprise, there is no way to change the wireless connection on the app for home monitoring. The only connection that one can change to is ethernet.
I had to eventually delete the hub to add it back again to different network. While deleting, I received a warning that it will also delete the sensors. I thought, it should be easy to add the sensors. But no, I was so wrong.
Those damn sensors do not connect. They keep telling me to take them close to the hub. I thought ok, take one out and take it near to the hub. Well, Wyze provided glue stickers to sticks these sensors to the walls and doors, if I take one out, I have to find another sticker to put them back. Anyways, I peeled one off and took it near to the hub and the stupid sensor keep telling me to take it to the hub. Th F thing is sitting on top of the hub and still not able to connect.
Ok, so lets try to add the keypad…same story…not able to communicate while sitting right next to the hub. I have not peeled the 2nd connetiction sensor and the motion sensor, but I know it will be the same story.
online troubleshooting documentation is pathetic. And they say, find a way to reach out the WIZARDS. Well all the wizards are always sleeping at wyze as no one answered my call on Thursday and Friday while I was on hold for more than 30 minutes.
Submit the log is a joke. I dont think anyone ever looks into wherever they are sent.
It’s been few days and no way to fix this monitoring system created by jokers.
This is my last attempt hoping someone is watching this. If not, this product is going into dump and I am going to cancel my monitoring service.

Thanks for spoiling my weekend trying to troubleshoot this crap of product you made Wyze.
A frustrated customer

Not sure how to fix your main issue but I’ve found using a small screwdriver to remove the sensor case from the backing piece that is double sided taped to your wall, as if you’re going to change the battery, works well. I only mounted one of my entry sensors incorrectly so that I can’t do that. Hope that helps a little. I’m having issues with HM as well and still no answers. I also lost the majority of my new-unopened V1 sensors because the battery went dead in the box :frowning:

Hello Lisag69,

There is a reset button at the back of the hub. I pressed that button and started the whole process again. I unplugged the power cable from the back of the hub and took it to all the places where I’ve installed the sensors, The sensors registered fine.

Thanks for your response.