Wyze Watch - Defective - Stopped working on 2nd day

This is DAY 2 since I had my Wyze watch and I’m frustrated with it. It stopped working and in fact, the touchscreen isn’t working or even clicking what/when I want it to… or clicking at all. The only way I can restart it was through the Wyze app from my phone. I’ve tried recharging it and restarting it (through the Wyze app on my phone) but still nothing.

  • side buttons stopped working after the 2nd reboot (from the Wyze app on my phone)

I guess it’s only $20 I’ll never wear again… i am so disappointed.

If you contact Wyze, they’ll probably replace it or exchange it after they go through some troubleshooting. They’ve always helped when I encountered any problems (usually some troubleshooting got me going), but I’ve also had 1 camera and a set of sensors replaced.

I can’t express how great customer service has been.

1 Like

Very disappointed here as well. I got my watch, charged it up, failed to pair it automatically, partially paired manually, and stuck with the QR code on the watch face. So the watch is useless at this point. II was hoping support will come to rescue but support has not been responsive so far.

Support does take a while to get back with you, unless you call (they used to have a way to call - haven’t needed to in awhile so I don’t know if they currently do).

I purchased 3
1st one seemed more accurate w/ sleep than my galaxy active 2
second day the app says 28minutes sleep the watch says 4h32min and nothing will make them agree.
also max pulse seems to match active 2 but minium is up to 30 higher than the active 2 - which does much more freqent readings BUT it will show the readings in graph and when you’ve gone hours at roughly the same bpm and the ww3 is 20-30 higher low reading durring that time there seems to be an issue somewhere.

the 2nd watch blood ox after a long time keept saying put on the watch (i may be paraphrasing)

3rd havent tried yet
I realize the samsung and apple watch pairs to one device - but I figured with the wyze app we could pair multiple watches on account and could at least use on any device logged in to account
can do neither with it mind-numbingly stupid.

and the items don’t stay on the one watch face w/ most - heart rate only stays on several seconds once every 5 min -

5min??? - Continuous means continuous not once every 100 years (5min) I’m ok with the battery drain so why isn’t watch.
are they going to start selling a watch subscription so you can actually make it usable with things like heart rate continuously taken?

Oh man, I’m sorry to hear that… one of my sisters bought 2 and still waiting for her order to arrive. Hopefully she has better luck. I’ve already warned her with my issue — it is what it is. I’m just glad that it didn’t cost me more than $20–i was so excited to get it even with the wait but only to be disappointed.

I’ve already submitted my request for a return. Not really too interested in an exchange at this point.

I believe the manual said that it come fully charged out of the box but that was clearly a lie. Mine was completely dead which is fine because I just fully charged it for about 2-3 hours. It took me a little while to pair it because of the code too—it wouldn’t read it or it kept disappearing lol finally caught it and was able to pair it up.

It worked for a day and a half even though it was slightly laggy. And then here we are —. But just because mine was defective, doesn’t mean they’re all defective. I hope others have better luck with their Wyze watch.

Getting a refund before insanity sets in is a good idea;-). I did not see a way to return on their web page though.

There you go! I got an email that they received my request for a return so we shall see—

Another weird thing is that mine displays things in Chinese by default!

Hope there is no baked in Spyware
Of the two I opened one had screen protector just was in the box below (no on) watch
Other the tape circle to cover the tab was just stuck on middle of side of box… that one the screen protector was on.

I’ve had the watch for nearly a week (6 days) and continue to have the same problems.

Steps are 1000s short of actual activity. I can walk for hours without recording a single step on the Wyze watch while my Oura ring and Hband watch have no problems.

The only notifications reported are phone calls. All others are allowed.

Sleep data reported on the app does not correspond with that reported on the watch. The data on the watch is more accurate than that on its application but differs from that reported by the Oura ring, Hband watch, and ResMed sleep monitor. I don’t expect exact correspondence but something somewhat similar.

Wyze data is reported on the Google Fit application. I don’t think that the Watch is defective but I do suspect that the app and the firmware needs work.

Welcome @xXAprilXx!
Anyone with issues should contact Wyze Customer Support about this issue as @towelkingdom suggested.
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT
Or online: Wyze.com/support
phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.

1 Like

Thanks! I’m in the process to get it returned. :slightly_smiling_face:

I’m sure if you contact Wyze they will replace it.