Wyze watch - can't use as trusted device on android

android has a feature to keep the screen unlocked when trusted devices are connected. the wyze watch seems to connect directly and doesn’t show up in the paired devices list and so I can’t use it as a trusted device.


That is strange. At first I did not see it there in trusted devices, then after making sure the watch was connected to the app, it showed up. I have added to the trusted devices and that seems to have worked. I have since stopped wearing the watch for many reasons.
Maybe after they rev. the firmware a few more times, and provide better faces and apps I take it up again.

I have it set up as a trusted device on my phone. I had to go to Bluetooth settings and pair it first, but after that I was able to add it in the trusted device settings.

Initially I used the wyze app and connected via QR code scan. Didn’t how up in bluetooth devices as paired and couldn’t be used as a trusted device. Seeing these posts, i removed from the wyze app and paired with android, I then scanned the qr code and now the device doesn’t show up as paired or able to be used as a trusted device. Wyze FIX THIS.

I am on a samsung Android phone using android 11 and oneui 3.1

I too don’t show my Wyze Watch 47 in my Android’s Bluetooth devices list, which precludes me from setting it up as a Trusted Device to unlock my phone.

I followed the QR code scanning method for setting up my phone as the manual says nothing about Bluetooth pairing.

I’m hesitant to unlink my watch and pair it first via Bluetooth, then via the QR code, because per the posts above one person was successful and one person no longer can connect their watch at all.

Any updates to this? I even have toggled an Android Developwr Option to basically show all nearby Bluetooth devices but still no entry for the watch :thinking:

Hmm, Wyze doesn’t seem very interested in fixing this issue. Very frustrating.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.