Wyze v2 Camera not taking Webcam firmware. I can't get Solid Blue Light

Would LOVE some help! I’m tech very savvy, but even I am struggling. The Instructions are VERY simple, yet, neither of my v2 Camera’s are taking the Firmware.
I put the “demo.bin” file onto the Root portion of the 128gb micro sd, inserted it back in, then held down the "setup"button and plugged it in… It shows yellow, a flash of blue, then yellow, then drops and Says: “Ready to connect”. Every Single Time! It wasn’t ever going to solid blue. I thought, maybe the 128gb was too big, so I grabbed a 32gb. Formatted it, and did the same thing, following the instructions to a ‘t’. Still, not going to solid blue.

Any Ideas?

Did you verify the hash (checksum) of the downloaded file??

I am having the same exact problem.

I figured it out!
I configured the camera again for security use. Then once I was in the settings of the camera, I grabbed grabbed a new Micro SD, but I don’t think it needs to be new, I formatted the card from the camera.
Then took the card out, added the “demo.bin” and the Mac xos file to the sd card root.
Put it back into the camera, held the Setup button, And powered it on, and it immediately took. The blue light came on and it works beautifully on my Windows 10 pc AND my Apple MacBook Air.

1 Like

Thanks – about the same time as you answer came in I tried using a 32G Micro SD and it worked. Prior to this I had been trying larger SD’s and another post on the blog indicated that the card had to be 32 GB, so I tried it and seemed to verify that 32GB is a requirement. Do you know if the new card you tried was 32GB?

Thanks again for your response.

That is also what I was doing… I was trying it with a 128gb that my camera was using for storage, so I assumed you could be used for this. The new add card was a 32gb, and it worked right away. Didn’t care to do much more research as to why it wasn’t working before.