Wyze Thermostat zoning support

I finally received my 2x Thermostats. I opened one to install and found that it does not support multi-zone installation. It was a big disappointment for me as I am a big Wyze supporter and I expected that Wyze Thermostat supports same features as big guys.
I have TACO SR503 controller and Honeywell thermostats. In our area in Long Island, multi-zone HVAC is very popular and luck of support of it could only be explained by considerable cost increase in thermostat unit.
Does anyone knows if Multi-zone will be supported in the future? Or is it hardware dependent and current model of the thermostat can not support it on the hardware level? Similar question was asked before but it was 3 month ago and I hope there are more info now.
Is there a workaround to make my 2 Wyze Thermostats work with my current setup? Or should I return it?
Can I return open unit? I have never considering returning any other Wyze devices before.

Happy Holidays to everyone.
Does anyone has any comments?

I’ve just completed connecting my (1) new Wyze thermostat on one zone (downstairs) of our 2-zone (upstairs/downstairs) forced hot water system. I have the 2-zone version of the same controller as you ( TACO SR502). My old thermostat was a programmable “dumb” thermostat with just 2 wires (R & W). Since I needed to run a new 18/3 cable to add the C wire, I took the opportunity to relocate the thermostat to a new location (family room where we spend more time) so it will better be able to “see” us coming and going than the old thermostat in our little-used dining room.

Long story short, I connected R and W to the Zone 1 thermostat terminals (upper right on my SR502) and connected the 3rd (Green in my case) to the COM side of the 24VAC/COM block (upper left on my SR502). At the Wyze thermostat I connected R to Rc (top left) W to W1 (lower left) and the Green “C” wire from COM on the TACO board to the “C” terminal (lower right). I made the mistake of initially connecting my R wire to Rh (lower left) thinking “I have heat only, no A/C” so Rh (red heat) seemed logical. When I did that, T-stat did nothing (no clicking, no lights, no boot). The installation walk-through seems to figure out you have just 3 wires that way and apparently switches to heat-only mode. This part is a little counter-intuitive IMHO and could perhaps use some clarification in the instructions. Perhaps non-engineers just follow instructions and don’t over-think it like I did and it’s not a problem?

Anyhow, with Red on Rc, White on W1 and “C” connected to COM on my TACO SR502, the thermostat seems to work. I personally don’t need a smart thermostat upstairs – the original “dumb” thermostat has been set on 55 for about 30 years – we like it cool for sleeping and enough heat rises from first floor that it’s usually a comfortable 60-65. That said, based on my hookup experience, I don’t see why a second Wyze thermostat wouldn’t work up there – at the end of the day, if you forget the “smartness”, all it does is close the circuit between R and W to call for heat, keep it open otherwise.

YMMV as they say, but soo far, “works for me”… I’d be very interested in hearing (Wyze @Brian ?) if I’ve missed something and/or what trouble this may cause such that Wyze doesn’t “support” this setup…

1 Like

Thanks for answering and posting your setup.

Unfortunately my setup is more complicated. I have 5 wires coming to my thermostat: 2 are going to SR503 and 3 more going to forced air HVAC unit. When I select all my wires in Wyze app it says that it is not compatible.
Rc,W > SR503

The second zone has the same setup. And I also have radiating floor in the kitchen connected to zone 3. That thermostat has the same 2 wires you have and there is no connection to anything else.

yep – that’s more complicated alright! I’m not an HVAC person so I’m not going to start guessing. I imagine that the radiant floor zone (3) could be fixed by adding a “C” wire connected to COM in the Taco, but no idea how you’d handle your other two zones. Hopefully one of the Wyze HVAC experts will chime in and help you get this sorted. I’ve seen @speadie address some of the more complicated setups on other threads so perhaps he’ll see this and know what you need to do…

Sorry not more help – good luck!

Looking at https://s3.amazonaws.com/s3.supplyhouse.com/manuals/1351150859758/85267_PROD_FILE.pdf

On your current thermostat, Y and G are both running from the voltage that Rc creates?

and W is running off of R? that seems backwards.

Rc should be the cooling system’s transformer. Rh or R should be the heating system’s transformer.
Can you verify this?

You need to have Rc and C connected to the wyze so that it can power itself. After disassembling my adapter, I think you should be able to use it with G and Y without W if you need to get a common back from the air handler to power the wyze. If not, you might need to run a common from the air handler to the thermostat location.
The wyze can switch Rh to W and Rc to G and Y, as long as the common it has is coming from the Rc transformer.

1 Like

I got confused by your answer. I guess I don’t have enough knowledge how it works.
In my setup there are two independent cables:
One is coming from furnace controller - Rc and W wires
Another is form air handler/AC - Y, G and R

I can power thermostat from the controller using Rc and provide C or C-adapter. But it’s not the point.
Will thermostat be able to work with the controller if there is another thermostat that could start furnace. There should be a reason it’s not supported by Wyze.

Your zone board should take care of starting the furnace, no?
Unless you have 2 different thermostats controlling the same wires for your cooling? Is that the issue?
(Heating is zoned, cooling is not?)
The reason wyze is listing it as not supported is because your R and Rc terminology is switched.
I think if you told the wyze that you have a Rc and Rh wire, it would be supported…
See this:

1 Like

@lmgray I can’t say specifically, but a lot of these homes with this type of system only had a 2 wire sleeve ran to the thermostat. Even with the included C-Wire Adapter, the end user would still be missing the 3rd wire for Common. Luckily, you were able to run a new 18/3 wire to provide this Common.

Hi Speadie.
Your explanation along with linked article totally made sense!
It took me some time to figure out some wires: I have a valve on return line to furnace connected in series between controller and thermostat (Rh,W wires).
I also have some (temperature?) sensor connected in series in G line between air handler and thermostat.
Once I figured these out I connected Wyze thermostat. Using CWA to power thermostat failed so I used spare wire. Once powered, I got an error that G wire is an “extra” connection along with all other unused connections. Repeated tests did not solve the problem, so I proceeded with that error. Test run failed on both Heat and Cool.
At the same time Thermostat got a firmware upgrade. My last resort was to reset and start over.
After reset to defaults Thermostat did found G wire to be proper and Heat/Cool test worked!
I spent like 12 hours in total on something (including research and the forum) that should be 30 minutes installation.
Thanks a lot for taking time and helping me!
Also, thanks to @lmgray for trying to help me and tagging right people here.
Tomorrow I’ll install the second thermostat for the second floor zone.
I will buy another thermostat for heated floor in the kitchen. It should be the same setup as pictured by lmgray above.
Thanks again everyone!

1 Like


I have a TACO SR504 - for four zones of hot water baseboard. I setup it up exactly as you did with my TACO, and the WYZE app came back that the W1 wire was missing, I could not make it go away.

Next, after consulting youtube, I tried an external 24V transformer for the power (Rc and C) and then used Rh and W1 for the heat call. This setup worked but the TACO relay kept opening and closing (the heater starting and stopping along with it) every few seconds, regardless of having a heat call or just being idle.

I am not sure what to do. I have emailed support for both TACO and WYZE, but nothing substantive back yet.

Any ideas?

Do you have AC connected to your thermostat? Please send a photo of connections on your old one.
I assuming you don’t, as you used Rc for providing power.
Two things to verify:
Make sure you have the latest firmware installed on your Wyze Thermostat - I had issues with that.
Is your external PS just a power transformer? Do you get 24-27 V AC on the output? Check wiring from your TACO - use spare cable instead (if you have one) for common (C-adapter did not work for me) and eliminate external PS.

Did you reset your wyze thermostat and tell it that your “old thermostat” had the following wires during setup: Rc, Rh, W1, C?
If you skip this step, it will combine the voltage sources on Rc and Rh instead of keeping them separate.

Thank you for responding and for your help

I have three old thermostats:1 - an old mercury dial switch with just two ports which are unmarked.
2 - I have a Honeywell with only an R and a W for heat - it has ports for cooling and fan which are not connected
3 - I have a Rite temp with the Rh and W connected. It has an Rc and other ports for cooling which are not connected.
On the fourth set of connections on the TACO, my water heater is connected as the boiler heats a water jacket around it. (No changes are planned for that circuit.

On the WYZE, I used Rc and C to the external transformer - which provides 24VAC
I connected Rh and W1 to the R and W ports, respectively on the TACO

I only did this because on my first try, I connected the WYZE Rc to the TACO R port, WYZE W1 to the TACO W port, and the WYZE C port to the TACO C port (I have a five wire cable). The app said missing W1 wire when I tried to configure the setup That is when I went to youtube to see what others had done for a two wire system.

Any ideas?

Thank you for responding and your help.

No, I did not tell the setup routine that the old thermostat had those connections. I just indicated Rc, W1 and C. I will reset it and do this tomorrow. The thermo has the latest firmware.

That was the problem. You had to indicate Rh not Rc. It looks like you don’t have cooling attached to your thermostat, just heating.
I recommend that you disconnect your external PS, Rc connection confuses thermostat into thinking it will control cooling, and only connect Rh and W1 from your TACO as well as C. Then reset your thermostat by holding down button for 10 seconds and start programming again. Make sure you indicate Rh, W1 and C. That should work.

The wyze will not power on unless you have Rc and C hooked up.

Thank you for your help.

I found out that it was a bum thermostat. I have successfully installed two others and they are working great. I’ll exchange the bad one and then will be all set.

Thank you for your help.

I found out that it was a bum thermostat. I have successfully installed two others and they are working great. I’ll exchange the bad one and then will be all set.