Wyze thermostat setup failure

Hi: I installed the Thermostat and can connect to WiFi. Once it connects it goes to a screen to personalize your settings. At that point, the app says the WiFi is not good, please try again later. It will not allow me to go further, or get to the troubleshooting section of setup. I am using a 2.5 g WiFi, and have rebooted and tried to reinstall the thermostat 4 times on an iPhone and 4 times on an iPad. I Even deleted the wyze app, and re-installed it. I cannot delete the thermostat out of wyze either. Any thoughts? Thanks for your help.

1 Like

There’s another thread on here somewhere, where other people are having the same problem. You could try pressing the knob for 10 - 15 seconds to reset & try again.

Thanks Ken. I have rebooted the thermostat at least a dozen times and even opened a new wyze account and did the setup there as well. No luck. Love Wyze camera’s, but this is not a good situation, and the other thread foes not seem to resolve the root cause either.

1 Like

I have this issue too. The thermostat was added in Alexa. The WiFi credentials are good. The thermostat is partially added in the wizen ap so you can’t get to the gear icon setup to delete it. It’s in a Zombie state!

That is the exact same issue I am having. Just rechecked all of the wires on the unit, rebooted the thermostat 5 times, and tried going through setup the same number of times. I get past the point where it says you are connected, you can personalize the settings and then it locks up and says the network is no good.

1 Like

If you remove one of the wires other than red or blue, you will see that setup will display the disconnected wire. Setup is indeed connected to the thermostat! The setup logic is flawed and displays an incorrect error. Wyze needs to fix this incorrect error loop!!!

1 Like

Yes, That’s what mine is doing. The thermostat was added to Alexa over WIFI, so the “network is not good” error is bogus. I believe an error is being thrown that the app error handler cannot locate in its code, so displays the error we see-then there’s no way out of the loop.


Trevor Alaine

Exactly. I removed mine and replaced it with the old thermostat. The furnace turned right on.

I have the same issue. Put the old Honeywell stat back in.

Have had this same problem and it’s incredibly annoying how bad the app is. You can’t delete the thermostat from the app. Bad move on Wyze’s part to release a product that is not ready for prime time.

Have had thermostat installed and working since January - no problems. But had an HVAC system problem other day and in the course of troubleshooting it I deleted the thermostat from the my app. Got HVAC issue resolved (nothing to do with thermostat) and when system came back, tried to add the thermostat back but could not pair to my phone (which it had been paired with). Thermostat said heating to 72. So figured that settings were stored in cloud and thermostat would continue working but I would be unable to control it from the app until I could get connected. Half hour later it was 78 degrees in house. Went through resetting thermostat, trying to re-add and could not get past the Mounting phase because I failed to check the “My system is still off” checkbox. Once realized that mistake was able to get back to pairing part and was able to pair but when opened app there was no Heat Mode in the controls , only Cool and Off. Checked wiring and realized in my HVAC troubleshooting I had removed the thermostat wires and that I had misplaced the white wire on the Rh teminal instead of W1.
Have tried resetting thermostat, deleting and re-adding it. But Heat Mode still does not appear.

Hi, does anyone know if this issue has been fixed? I uninstalled my thermostat and did not want to try again until I was sure it would work. Thanks

I sure hope someone can report some good news soon.
I have two of these thermostats sitting on the shelf waiting for a fix.
I spent two hours trying to get it to work and kept getting the no connection issue
mid-way through the setup. I finally gave up and put in a LUX Kono.
I may have to resell these Wyze Stats.
But, I would really like to use them.

Issue was resolved. I went through the setup so many times I stopped paying attention to the wires I said my system had. Did not realize that the wires you choose affect the behavior if the stat. Once I corrected that, full functionality returned.

Sorry for not updating/posting here.

The original issue that started this thread was that the WIFI would be connected at the beginning of the setup process. But halfway through the setup, the Thermostat would say ‘No Wifi’ and then be dead in the water.

That issue is the one that nobody seems to have resolved. The WIFI is good and gets connected at the beginning but then reports to be ‘no wifi’ during the ‘personalize your settings’ portion of the setup.
I know it is not my wifi as I tried it with three different Internet connections. A wired connection, a cell phone connection, and a Myfi hotspot connection. All three were good Internet signals, and the stat did the exact same thing on all three.

I am glad that you were able to fix your wiring issue, but this thread was about the setup not working all the way through.

AND it would be really great to know if the problem has been solved by the company, They told me they were aware of the issue and a fix was forthcoming but I have not heard or seen anything to suggest this is the case.