Wyze Thermostat Schedule Uses Wrong Time

My Wyze thermostat isn’t running the schedule at the correct time. The schedule feature was working fine. Then I went to India (and checked the Wyze thermostat remotely from there.) I’ve been back a week and the thermostat seems to be running the schedule in India time. It goes into Sleep mode at 11:30 am Chicago time instead of the 11 pm Chicago Time set in the schedule. Seems to have stopped syncing time from my iPhone and is stuck in India time. How do I get it syncing time again??? Factory reset? Is there any way to find out what time the thermostat thinks it is? That would be a very useful feature.

Welcome to the Wyze User Community Forum @wilsonfamily! :raising_hand_man:

Seems like the phone, app, server, and thermostat need to all get back on the correct time zone.

Check in the Thermostat Settings → Location to be sure it is showing the thermostat is located stateside in Chicago and it didn’t somehow get reset to India.

If that doesn’t help, I would:

  1. Clear the app cache in Account → App Settings
  2. Sign Out of the App & force close
  3. Pull the thermostat from the wall plate
  4. Restart the phone
  5. Verify time sync in the phone OS is active with carrier and not manual or with any correction
  6. Sign into app
  7. Plug thermostat back into wall plate and allow to boot up.
  8. Open thermostat in app and verify the Thermostat location is set to your address stateside and all schedules are set to local time
  9. Set and save a local time schedule block to test if executing appropriately.

Thank you for the suggestions. But the location is set correctly and I went through the suggested sequence and it had no effect on the problem. Expressing it as a 24 hour clock, the thermostat goes to sleep mode at 12:30 (I thought it was 11:30 at first) when the schedule is set for 23:00, so it’s 10 ½ hours fast. Or is it 13 ½ hours slow?

If there aren’t any more ideas, how do I do a factory reset of the thermostat so I can try reinstalling it? I guess an alternative is to set the schedule for sleep mode for 9:30 am so the thermostat will actually go to sleep mode at 11 pm. This is a strange problem for a thermostat to have.

It is odd for it to do that. This is the first I have heard of it. Because this started when your phone was switched to India time, I suspect that it is an issue between the phone and the app that isn’t being registered in the server where the schedule settings are stored.

Don’t delete it from the app just yet. You can try to do a device restart at the bottom of the Settings menu and see if it will resync. After that, pull it off the wall for a couple minutes and then plug it back in. If that doesn’t resync it, try deleting the schedules and repeating. If that doesn’t work, you can do a factory reset in the dial menu on the thermostat. You can then reinstall it without deleting it from the app. If that fails, the last option is a delete, factory reset and reinstall.

One other question. I think I remember setting up a Bluetooth connection to the phone when installing the thermostat, but I don’t see a Bluetooth connection on the phone anymore. Is Bluetooth needed to sync time? How would I restore it?

Yes. You will need to have Bluetooth and GPS enabled if you do a repeat setup. It automatically happens during setup. There is no setting in the thermostat for that and it isn’t something that you would have to manually pair.

I don’t use iOS so I can’t tell you where the BT or GPS feature toggles are on the phone. But those do need to be on.

I had to go to the last option to fix the problem. I did a factory reset on the thermostat and deleted & reinstalled the app on my phone. After reentering the schedules, everything is happening correctly on Chicago time.

1 Like

I am glad you got it fixed. Not sure why that happened. If it comes up here again, I will know who to send them to.