Wyze thermostat not working after new eero Pro 6 modem/router installed with fiber-optic internet connection

wyze thermostat not working with new eero pro6 router/modem. Wyze installed 11 months ago and worked fine until eero unit came with Frontier fiber-optic system.

eero is dual band 2.4 and 5gz wifi, but will also let you pause 5 gz for ten minutes to help hook up older 2.4 devices. Did just that for numerous wifi smart plugs and for wyze cams. (Some wyze cams v.3 just worked without disable 5 gz).

Used same internet Network Name and same password as before eero, and everything except Wyze thermostat now working.

Went through complete delete thermostat and reinstall 4 times now. Will finally get message that thermostat is connected, but shortly says cannot detect network. Cannot control HVAC system with android or the thermostat itself.

HVAC system was professionally serviced less than a year ago, and was working perfectly during 2022 cooling season. Now 88 degrees fahrenheit in Florida.

Help! I’m ready to rip out and toss WYZE thermostat and put back in the old non-smart one, if I don’t hear back from you soon.

I’m just trying to put this into perspective so you can live with some non-results. Specifically, don’t look, don’t expect someone from the Wyze Support Team to jump in and offer help or advice. This is a User forum. We are customers like yourself. There is a select group of highly motivated and Wyze-smart moderators that will likely chime in and offer some ideas, though.

Don’t wait. You need to contact Wyze Support directly, open a ticket and talk to someone to get direct help. Now, having said, all that, I might suggest something really non-thermostat related to try.

I keep an old router. You likely still have your previous router it will do. Since you said you are already using your former SSID and password, I would try this:

  1. Unplug power going to your eero routers. Don’t remove them, just power them down.
  2. Unplug the cable modem and plug it back into your old router.
  3. Using the old router, join the Wyze thermostat to your network with a fresh connection to your network.
  4. Once you know its working, simply unplug power and ethernet cable from the old router, and plug the eero back in. If relatively near your thermostat, you likely can get by with bring one eero back online, but will not matter if more than one. Of course if the distance between the main/root eero router connected to your cable modem is “some distance”, place one of the eero nodes about half way between the root router and the thermostat, and power both back up.

With a little luck, the thermostat should come back up online… If it was me, I would try turning off any other WiFi connected devices temporarily to “leave space” for the thermostat to come up quickly/sooner.

This may seem like too much extra work. But this is good experience to have under your belt. Or, you can not bother. Many of us try these sorts of things to learn what works and what does not.

Best of luck to you. Curious how it works out for you.

Literally having the exact same issue… I installed a new eero6 mesh system two days ago and now my wyze thermostat isn’t working. I have over a dozen other wyze devices which aren’t experiencing any issues.