Thermostat not resetting?

Background: I have had my Wyze Thermostat from a little over a year. Every feature worked as expected. Recently, I changed ISPs and got a new router with a new SSID. Since you cant simply change the wifi on Wyze devices, I had to delete the thermostat from my Android App and hold the buttom on the thermostat to factory reset. I went through the process to add it back and now I’m having problems.

Problem: I no longer have an option for Fan control. I used to have it and it worked perfectly as expected. No wiring has been changed. The fan works fine during heating & cooling. I have since tried the reset process 3 more times with no luck. I just can’t get the fan control back.

Additional details: Something doesn’t seem to be interacting as it should. In the ‘Device Info’ panel, it shows todays date as the activation date, since I reset everything, but it shows the previous wifi SSID, not the current one. The previous SSID no longer exists and I can see the thermostat clearly connected to my new router on the new SSID. Additionally, it was weird that during the system test, it asked if my radiators were heating up despite previously selecting forced air. Anyone know what is happening?

Edit: The info screen on the thermostat itself shown ‘unknown’ as the network and ‘0.0.0.0’ as the IP, but my Eero router clearly shows it connected, with a valid IP, and I can access it from the app.

I think you have to do the full setup again. The first steps should connect it to the internet. Also when telling it what wires you have the G (normally green wire) should be part of the setup. G is the fan accessory circuit.

So I figured out the fan part. I have a 4-wire setup and used the Wyze C-wire adapter on my initial install. When adding the thermostat again, the app does a poor job of reminding you that you might have installed this small component over a year ago that you haven’t seen since. Once I marked the wires as my OLD thermostat used them, I was able to get it set up properly with full fan control. I still haven’t figured out why the network information is not displaying properly.

That part appears to be a bug in either the app, the thermostat, or both. The thermostat is currently connected to Wifi and working properly. I have full control of it via the app. The problem is that it is not displaying accurate information.

  1. The app ‘Device Info’ for the thermostat shows it connected to an old SSID using a particular IP address. The SSID shown is from a previous router that no longer exists. At this point I have factory reset the thermostat 5 times and set it up under my new SSID.
  2. My new router shows the thermostat connected to the new SSID using a new IP address.
  3. The thermostat itself is showing that it is connected to an unknown network with no IP address.

It is obviously connected to my new network, but nothing seems to be displaying properly. Since I have factory reset the device 5 times and deleted it each time from my app, I am not sure how it even knows my previous SSID.

The App Info is pushed to the App from the Server. Much of that info is most likely stored in the App Cache and being pulled from there to speed up load times. It also may take some time for the server to be updated with the new data from the Thermostat. You can try clearing the App Cache, logging out, closing the app, force closing the app from the OS so it isn’t running in the background, opening the app, logging back in, and seeing if the app pulls the new data from the server.

But, since it is informational data only and not critical operation data, so long as it is working it may be something that just needs time to update.

From Support:

The situation you described, where the device info in the app shows the previous SSID and inaccurate information on the Wyze Thermostat, has indeed been identified by our engineering team.

The engineers detected that due to the gateway change in firmware 1.2.7, device information upload sometimes fails to execute normally which results in the Wyze Thermostat not getting or uploading device information such as WiFi name, IP, wifi MAC, Bluetooth Mac. I want to assure you that while this issue might be present, it doesn’t affect the normal operation or control of your Wyze Thermostat. However, we acknowledge the inconvenience it causes in terms of accurate data display.

Our engineers are actively working on a solution, and there’s good news! A new firmware update is currently being tested to specifically address and resolve this issue. This update aims to ensure that the information displayed on the Wyze Thermostat aligns accurately with the changes made to your network settings.

1 Like

1… Its ridiculous that I had to reset because we got new internet
2… Now the same wiring from before is not working. The fan will not go on now

Insane!.. Also the doorbell battery last 5 days new out of the box… 2 cameras wont re-register as they wont read bar codes…

If you are using the C adapter, you need to tell it that you don’t have a C wire, but instead have a G wire or it will not be able to control the fan.