Wyze Thermostat frequently crashes when adjusting temperature, plus fails to restore wifi connection

I have a couple of Wyze Thermostats, and one works fine, but the other one very often will crash when I adjust the temperature using the physical knob. Specifically, the thermostat will be functioning, turning on the heat/AC when the temperature threshold is reached, so I know it’s still “alive”, but as soon as I turn the dial one notch, the screen lights up with the temperature adjustment UI, but then it freezes – the virtual dial doesn’t move to the next increment and no longer responds to the knob being turned. After a few seconds, the screen goes black, then shows the Wyze logo, seemingly having reset/rebooted. Once it finishing booting and reconnecting to wifi, then it works for a while, but inevitably will fail in the same way a few days later.

I’ve tried cycling power, resetting, removing/re-adding, but nothing has fixed it. It is on the latest available firmware as well (same as the functioning one). Has anyone else experienced this? Is it a common problem, or do I just have a defective unit that needs replacing?

On a related note, this same thermostat will also occasionally fail to reconnect to wifi if the power goes out, or the wifi goes down, or any other situation where the wifi connection is lost. In those cases it will never reconnect unless I power cycle the thermostat.