Wyze Switch, installation load plate failed

Hi,

I’m trying to connect my new Wyze switch, but when I was screwing the wire in load the plate inside the Wyze switch fell, how can you solve this?

1 Like

Welcome to the User Community Forum @luiser61!

Unfortunately, I am afraid you are going to be replacing that switch. I would not be comfortable installing it even if I were to get the board and screw to pull back out. Very likely possibility of internal damage and short out potential.

It looks like the underlying board support has completely failed. And from the looks of the screw head, support board, and case opening, I would suspect it let loose under great duress.

There also appears to be evidence of some type of arc burn on the tagged wire and arc flash on the side of the switch (black spots and black clouding).

Be sure to inspect all wires thoroughly before you install a new switch.

5 Likes

Same thing happened to me .

You cannot unscrew the terminal screws more than a little bit or the washer underneath will break and then it doesn’t tighten the screw.

Cheaply made switches from Wyze tbh

I went through 5 switches , and my current one is messed up as well . I have 1 more switch left and I honestly don’t even feel like installing it bc it’ll end up getting messed up in the process as well .

Hello @luiser61 and welcome to the community.

I am sorry you have had this issue with your Wyze Switch. I would agree with @slabslayer and would advise against using this switch. I would try contacting support and see how they can help you.

Wyze Support

(206) 339-9646
Mon - Fri 4am - 8pm PT
Sat - Sun 8am - 4pm PT

1 Like