Wyze sprinkler, no power

I received my sprinkler and nothing lights up at all. I’ve tried it with and without the sprinkler wires, with and without my sensor and have tried two different outlets. The AC adapter seems to be working as it gets warm after being plugged in.

I submitted a ticket (Wyze Ticket 1025917) but have not heard back in several days. Any advice?

I just completed setup (wiring/mounting) of my Wyze Sprinkler Controller. I plugged the AC adapter into a known good outlet (same one from my RainBird), tested presence of power at the adapter with an AC tester, but got none of the orange pairing lights. I unplugged and plugged the barrel connector at the back of the controller, heard a humming sound from the AC adapter, followed by a pop and trip of the circuit breaker. Smoke billowed out of the AC adapter and it was hot to the touch. I’m hopeful there is no additional damage to the existing irrigation system. I just submitted my support request and received a Wyze Ticket from an automated customer service solution. I am hopeful for a prompt response. If not, the issue/matter becomes clear - this is my last Wyze product purchase and I will campaign against friends/family/etc from buying Wyze products.