Wyze Sense Hub Firmware Released 7/7/2022

We know that some folks have been waiting a while for this firmware update and we really appreciate your patience! Wyze Sense Hub firmware is releasing today with bug fixes for sensor pairing and connection failures. :slightly_smiling_face:

Read our Release Notes:


Yes, I am one of them…I will have to try updating my hub now (I’m still on 2021 firmware)…been waiting for this resolution, and I am really excited that the recent updates this year should also make my hub volume louder! :smiley:

1 Like

Ditto that! But I will wait a few days to see other folks outcome.



I know this went through a lot of QA & Beta, but I will probably give it a day or two as well. Also any issues upgrading to if we are still on


Very good question @claystorm.

Mine is on .213 and shows update available to .249

@WyzeJasonJ, will the update version in the app change to ,264? If I update now, with .249 showing, will I get .264? Or, will I need to step thru all the updates to get there? Thx!


That is a good question, and I do not have the answer but let me see if I can come up with an answer.


I am on x.7.177 and also showing an update for x.9.249 instead of x.9.264

So it does look to me like we have to first upgrade to the buggy firmware first as an intermediary step, then hope we can upgrade to the 9.264 after that. I’ll be a guinea pig and try it out. I trust Jason and Gwen for making sure support helps out reasonably if needed. Here it goes. I’ll report back later.


Appreciate you. Looking forward to your results. Also is your hub connected via WiFi or Ethernet?

1 Like

You are so brave. That is so altruistic… Taking one for the team.

New firmware…new drama.


Would you expect anything less at this point?

@WyzeJasonJ (and @claystorm ) here is my report:

I have a hub plugged into Ethernet. Hub had firmware (released 12/8/21)

It was showing an intermediary firmware update for

  • To process this update I went to the hub from the Home Tab and selected Settings → Device Info → Firmware Version → Update
  • This update said it could take up to 10 minutes but it took less than 3 minutes. It was successful.

I was then presented with another update for firmware

Log 638275 (submitted right after the update failed and before anything that is listed below this sentence)

  • Sensors were not functioning.
  • I rebooted the hub (held the setup button for 9-10 seconds until the LED flashed, then I released it and let it reboot).
  • Sensor status was still not updating after the reboot. Sensor status was frozen.
  • I knew the hub was not bricked because when I selected the hub from the home screen, it would pop up and tell me it recognized there was a firmware update available for it.
  • This time I told it to update the hub to the new firmware through the pop-up that prompted me to try to update again.

Update to was successful this time.

  • After the successful update, it seemed sensor status was still not updating (I tried multiple sensors and the open/closed state was not updating in the app, routines weren’t working, etc.
  • I then armed the HMS through the Monitoring Tab in the app. It armed successfully.
  • I then opened an armed doorway, and the entry delay successfully activated/beeped.
  • I then deactivated the alarm successfully.
  • After that, the sensors appeared to be working. Chimes, routines and sensor states were updating as expected.
  • I learned 2 of my sensors Tune settings were set to “Off” and I fixed that (note: I am guessing they were set to “Off” before these updates and I just didn’t realize it before now and that them being off is unrelated to the updates, though I am not 100% certain, so I mention it anyway) and reset volume by selecting Low then back to high. Chimes were working.

I next tested adding a brand new sensor

  • Adding the sensor itself went smoothly, BUT then sensors started having a weird latency issue related to cloud state change updates. Sensors will chime immediately (proving the hub is working fine, and noticing state changes immediately, but then not update or run routines for a while…often 20+ seconds, sometimes over 30 seconds (I didn’t continue to count any of the times I got over 30 seconds)
    Note: Latency length is not a consistent interval.

Log 638316 for the new contact sensor with an example of random latency state change in the app/cloud/routines.

Log 638351 for the hub for showing immediate chiming when sensors open, but state change in the app/routines can take over 30 seconds…sometimes they update immediately, but commonly having a latency of 20 seconds.

Overall, the HUB seems to be functioning as expected, minus the recent random latency after I added a new sensor (but they are functioning).

I will continue to monitor and see if this resolves on it’s own, I might try rebooting again later and see if that helps.

Jason, if you want me to try anything, let me know. As I said, I can always reboot again now that I have the newest firmware and see if that changes anything. I can also add more sensors (I have a few more I’ve been intending to setup). I’d prefer not to delete and re-setup everything since I have 46 active sensors (and a few others waiting to be setup, let alone all the routines connected to them all), but if that is really needed to check something for your guys I can get around to trying that too.

I’m not in a huge rush, and it is functioning, the latency is a little weird, and it’s possibly unrelated, so we’ll keep an eye on it for a minute. Just reporting all abnormalities just in case.

EDIT UPDATE: For those following this, as explained in a post below, the latency abnormality appears to have resolved itself within less than 2 hours (possibly in 15 minutes, but I didn’t check between 15 minutes to 2 hours, so somewhere in that time frame it resolved and everything seems to be working fine now).


Thank you for taking one for the team. I’ll hang out a few days and see what they say.


Thank you so much for the report. :heart: Our team will investigate based on your feedback.


Happy to help, especially happy to see you reviewing it. :slight_smile: Thank you.


@WyzeJasonJ @WyzeRyan just an update 2 hours later. I did not reboot the hub or anything since the final update to x.264, but now the previously reported latency issue appears to be totally resolved on its own. I tested multiple sensors and everything is currently working with a state change (open/closed status and routines) functioning nearly immediately, including the newly added sensor. Maybe it just needed some time to resolve itself? Either way, I wanted to report that I am no longer experiencing any latency with status/routines related to the hub sensors. So if your support crew gets someone reporting they are experiencing that issue, consider asking them how long ago it started. It might resolve itself in less than 2 hours (It could’ve been a lot sooner, I did not check anything in the last 2 hours, I just tried some new tests now and all worked immediately).

It seems I can provisionally conclude that the firmware update was ultimately successful with no bugs currently presenting. I will update if the latency returns or something else comes up, but it seems everything is now functioning totally normally. For those following up on this, don’t be concerned if you have latency issues at first, they appear to resolve on their own after a short interval of time. No other lasting problems that I can detect at this time. Looks good. :+1: Thanks Wyze Team.


Glad to hear that the system is working fine now. Yes, please let us know if you experience any abnormal. Cheers!


Is there any noticeable volume difference with the alarm?