Wyze sense hub does not connect to WIFI

I have TPLink Deco x60 WIFI mesh system and the Sense Hub would not connect to it.

So far I tried followings:

  • disabled 5 GHZ band on deco x60,
  • powered off all mesh nodes except for the main one.
  • ensured removing Ethernet cable completely from the Wyze Sense Hub
  • Disconnect my cell phone from the WIFI network
  • ensured there is no space at the end of my network SSID
  • Also there is no typo in the password since I have been copy pasting it straight from the deco app

Any additional tips? By any chance is it possible to reset the hub without having to re-add all the sensors?

Did you previously have your hub setup via Ethernet?

You need to re-add the hub to your Wyze app after disconnecting it from the ethernet cable. Don’t delete it, just do the add device process with it. You’ll then be able to enter the SSID/password. You need to just press the reset button after disconnecting the cable.

Yes indeed.

No success with this either.

Somewhere along the steps, it went completely offline and would not connect even with ethernet, the lights keep flashing.

Wonder if there is a way to do a power recycle - the battery makes that impossible - maybe I can disconnect the power and wait for a day?

There’s a bug that prevents you from going from Ethernet to WiFi. Not sure if it’s been fixed with the latest hub firmware, but it doesn’t sound like it. You’re going to have to master reset the hub by holding the hub’s reset button down for at least 1 minute. It worked the 1st try for me, but you may have to give it a few tries. Also, you may have to manually type SSID and password in vs pasting. After master resetting, your sensors will still be there… you may have to reset a few sensor parameters though like delay timers, so it’s a good idea to go over all hub settings after successfully moving it to WiFi.


Thank you for the thorough response, much appreciate it.

I tried with no success. :frowning: If I did remove and re-add is is possible to have it connect to WIFI directly?

That is exactly how I connected mine to WiFi after using it via Ethernet. Disconnect hub from Ethernet, delete hub from app, hold reset button for 1 minute or longer, re-add to Wyze app.


Worked like a charm -it is laborious to add all those sensors back, reconfigure monitoring and retouch the alexa routines, but it worked. In retrospective, when you are stuck it is best to use the big hammer. :rofl:

Thanks for your responses.


No special characters in your SSID password? Please don’t Not ever application can accept them. Since there’s few hints that this cold be an issue, best to simply avoid them always.

There are certain characters that seem to be problematic in the SSID name. However, I use spaces, commas, upper and lower case and other punctuation marks in my passwords without any issue.

1 Like

There we no special characters in SSID.

Its apparent the bug is in switching from wired-Ethernet to WIFI.

1 Like

Thank you for coming back to report your status. It’s great to hear you’re up and running on WiFi. :+1: If I had known about this bug prior to initially setting my hub up, I would have started setup via WiFi. It’s good to be able to better locate the hub untethered from CAT cable. When the bug is fixed, we should be able to switch back and forth at will between WiFi and Ethernet like the outdoor cam hub.