Wyze Sense Contact sensor seems to work, but no reports

I’ve had a contact sensor on garage door for some time, Was working fine, until the battery ran down.
Replaced battery. The Wyze app (iOS) no longer reports changes of state. It permanently report OPEN, regardless of location of magnet.

I’ve gone through all the troubleshooting steps I’ve found listed here. Still no joy.

The V2 camera is working fine. Reports latest firmware. Streams video fine.
The Wyze bridge seems OK. Reports latest firmware. Steady blue light on the back. It responds to command to change the status light mode in the app (can turn the light on or off).
The sensor appears to be on-line (i.e, it doesn’t show “offline”).
The sensor seems to work OK. Red LED flashes once when magnet is moved close to sensor, and again when magnet moved away.
Device status indicates battery level and radio signal strength both ok.
The battery measures 3.02V, in-circuit.

Force quit the Wyze app. No difference.
I’ve tried deleting the sensor device, then re-adding it. No problems with pairing, but that didn’t help.
Power-cycled the V2 camera. No difference.

Power-cycled the sensor (removed battery). No difference. However, after removing the battery, the device still shows it’s online, with Normal battery level and high signal strength, even though it clearly transmitting no signal. With the battery removed from the sensor, I restarted the camera. After a minute or so, the camera booted up, and the LED on the bridge went to solid blue. Yet the sensor still reports the battery is normal and the signal strength is 3-bars. Even though the sensor has no power.

Based on the above, I don’t think the root cause is a bad sensor, nor a weak battery.
Seems more likely that the bridge is bad. Yet it paired to the sensor successfully, so it’s not completely dead. And was working fine until the battery in the sensor ran down.

This definitely sounds like a faulty bridge or sensor. I would open a support ticket with Wyze.
Support link: https://support.wyzecam.com/hc/en-us

I tried a different sensor. Same problem.
This points at a faulty bridge, or a bug in the firmware.
But if the latter, others would have reported similar issues with the sensors…

Wasn’t faulty hardware. Not the bridge nor the sensor.
I deleted the Wyze V2 camera (into which the bridge was connected) from the app. Then added the camera back, and reconfigured it and the bridge+sensor. That seems to have fixed the problem - the status of the contact is now being reported by the Wyze app.

Conclusion - dodgy software. Fortunately not faulty hardware, as the camera and sensor are out of warranty. And in any event, as I’ve found with past h/w failures, Wyze wouldn’t provide warranty support for them.