Wyze Scale Problems

I’ve been a huge fan of Wyze for the past few years as we bought 8 Wyze cams to put around our house. Great customer service up until we purchased around 25 Wyze Contact Sensors and a Wyze Scale a few weeks ago. The Scale won’t measure anything but weight and despite trying to work with Wyze to solve the problem, we were told there’s nothing else we can do other than wait for the developers to fix the problem, and no one knows when that will be. We were told we can’t exchange and get one that works despite being told ours is an unusual problem. C’mon, Wyze! Don’t kill my faith in your company. I’ve been telling everyone about you! I’ve turned a blind eye to some of the products we ordered that didn’t work. Y’all took care those problems without issues.

1 Like

Hello @bstoddard and welcome to the community.

I am sorry you have had these issues, did support have you try anything to get it to work, if so what things have you tried?

Hi Jason. Yes we tried everything multiple times on three different occasions. Removing app, resetting, etc. Three support reps ran out of ideas and said it’s probably an app issue and we need to wait for an update. That came through today, and it’s still not working. I was told again to wait for another update. I don’t think it’s the app, especially if this is really out of the norm. We have LOVED Wyze. And we really want a Wyze scale that works as it’s supposed to. I have plans on buying at least six outdoor cams and other products as soon as we are able. It’s not a positive experience to be told sorry your product doesn’t work and Wyze can’t solve the problem other than we’ll just to wait hoping a future update at some point will fix the problem. Your company has been awesome with a few other faulty devices; not sure what happened here. I don’t want my money back, I’m very happy to exchange for a working one. We want the working product.

I do not work for WYZE, I am only a volunteer who tries to help out on the forums. You say the scale only measures weight, have you tried moistening your feet and then steeping on it?


I will chime in behind @WyzeJasonJ and second what he said about moistening feet. I was a tester for the scale from its inception and early on both keeping the surface of the scale clean ( like shiny clean), having it on a level spot and, if it failed to measure other than weight, wiping the soles of your feet with a damp cloth were things that would fix that situation. I haven’t had that issue in a long time but it just automatically do this now anyhow.
Hope it helps! I’ve found the scale to be a very good product and hope you will have the same experience.


I too initially had problems with the scale measuring only weight due to dry feet. Moistening my soles fixed that. Also had occasional erratic measurements due to thighs or calves touching.

This may seem obvious, but please check your settings to ensure the Only Measure Weight option is disabled/toggled off: Wyze app Home > Scale > Settings (gear icon in upper right) > Users > your account icon/name > Only Measure Weight > toggle off


Good morning. Yes, we have tried wiping the soles of our feet. We’ll continue to try that.

Good call-I missed that one. :thinking:

FWIW, my scale works as expected for me but had my folks give it a try last time they were over and it only did weight for them. Hopped on immed after and got full stats as usual!!

Wyze swapped out our Scale with a new one and it works wonderfully. Very happy with scale that works.

1 Like