Wyze Plugs will not reconnect to WIFI after power outage

I have a large number of Wyze plugs that are going into the dumpster. They work fine for a while then after a power outage they need to be reprogrammed as they do not reconnect to WiFi. Yes I have tried to all the reset procedures etc… I know these things are cheap but this could cause someone significant loss if they are counting on these devices. It is not my network as I have numerous other IoT devices like Sonoff , Shelley, and other ESP8266 devices that work fine.

I will have one of these devices analyzed to determine what has failed. Once that analysis is complete I will report back what was found. If it was one device I would chalk it up to a bad device. In this case I am talking over twelve all the same age. The reconnect functionality has worked in the past.

Just checked my Wyze Plug. Unplugged it, waited 20 secs, plugged it back in. The plug reconnected to the router, and the app can turn the plug on and off.
I did not test unplugging my router at the same time to simulate a real power outage since my router has a battery backup and it would take several hrs to power down.

Mine used to do that. I will know why mine quit working once it gets opened up and examined. Glad it happened now and not when I was on vacation thinking my lights were going on and off for security purposes. I am pulling out all the Wyze equipment I have. I don’t trust it. Never had a sonoff fail and they are much cheaper. I also had a camera die that was about 6 months old. Maybe I got all the bad equipment and yours will work forever!:grinning: