Wyze plugs not turning on or off

I set the rules to turn on everyday at 7pm and to turn off at 7am and everyday it just ignores the rules and stays off. So I turn it on remotely and then when it says to turn off it stays on u til I turn it off remotely.

Welcome to the Wyze community!
I’ve got a few questions:

  • how far away is the plug from your router?
  • have you updated the firmware (if needed)?
  • have you tried power cycling?


  • Are your rules setup properly?

Let me know if this helps!


Welcome to the Wyze community LexLuthor. :+1: If you read @Brlepage’s post and you’re still having issues with your Plug rule, could you post a screenshot of your rule like this?

Make sure the Enable toggled is On for your Rule.

Don’t try to make sense of my example… it’s a reverse logic rule for a fishtank light. :wink:

If you have your Plug grouped with other Plugs, make sure the group-level toggle is On:


I unplugged the second wyze plug and now the first one is working again, plugged the second one in and boom first one stops working again. The firmware says it’s the most update one.

It could be a problem with your rules, but I can’t tell unless you provide screenshots. It sounds more likely that you may have a network issue, either IP address conflict or max supported devices. You can test this by shutting down a few other devices on your network and see if both plugs work. The only other suggestion I have is to delete the Wyze app, restart your device and reinstall the Wyze app. Your devices and settings are stored in the cloud so you won’t lose anything. That may sound absurd, but it’s worked for a few users here. When you log back in, it will pull your previous info from the cloud into the app on your device. Other than that, you should call Wyze Support or use the web-based support system:

Wyze Customer Support
1 (844) 999-3226 or (206) 339-9646
Available Monday - Friday 5 am - 6 pm PT
Saturday 8 am - 4 pm PT

Please check your version info before you do either. You should be at the following:

Wyze app:
iOS - 2.11.41
Android - 2.11.40

Plug firmware:


There are so many problems with this app it indicates it’s neither intuitive nor user friendly to many people. Techs and geeks get it, but maybe not your grandma or grandpa. If Wyze only wants to sell to tech-savvy people, then warn them that they may have to mess with their router, try again, start over, etc… Warn them, that if they are using iOS they may have more problems than Android users. If your grandma or grandpa can’t easily set up a system Wyze has failed. They just see your products on Amazon and think “That sounds neat! Let’s get some”. Wyze emulates the Chinese standard of not actually providing anything but the bare minimum in the way of a user manaual.

Tech that relies on other tech is rarely “easily” setup by the majority let alone parents and grandparents. And if it is easily setup, it will fail as soon as the other end changes. Most modern tech has or is transitioning to “find your instruction and help online”. I’m a grandparent and I still prefer paper manuals/instructions, but it’s nice to have at least a .pdf. But I hear you, nothing like having to Google for answers to your not-so-simple “quick start guide”.

Doesn’t sound absurd, sounds like “cache cleaning”!


Well yeah, if you know you know what that means. :grinning: