WYZE Plugs and Ubiquiti Unifi issues

I have 8 WYZE plugs and my wifi AP is a Ubiquiti Unifi NanoHD.

The WYZE plugs all seem to not play nice with the AP has they have been having 2 issues for some time now. Happens ever couple days or sometimes hours.

They all will, one after the other with a few hours in between, will go “offline” where the LED on them blinks, and the Wyze app and Google Assistant say they are not available.
Yet, my Unifi Controller still shows them as connected to my Wifi, and is sending data.
I can use the controllers “Re-connect” option to force the Plug to become active again.

The other issue that happens, is that the plugs will just be “offline”, but the LEDs on them are NOT blinking. In this case, sometimes a force Re-connect in the Unfi controller will fix it, often taking multiple attempts, but often, a physical power cycle of the plug is needed.

In both cases, the plugs IP address does not respond to a ping. (the online plugs do).
I do also notice that the Unifi controller reports that the “offline” plug is not in “Power Save enabled” mode (the green leaf icon). The online plugs do show this mode, and when i Re-connect the plug, the Green Power Save mode enabled icon comes back.

I have updated/downgraded from several various versions of the NanoHD AP firmware, nothing has changed in this issue.
I have tried changing the 2.4ghz transmit power and channel…doesn’t affect this.

I have even sent in logs and had a Ubiquiti support employee remote into my controller and analyze things, and he can’t see anything wrong with my setup.

When i switch over to a small Linkys AP i have as a spare for the 2.4ghz band, same SSID and channel…the WYZE plugs stay online with no issues. Went up to a month with no issues that way.

I have a EdgeRouter ER-4 and (not Unifi USG) as my router. And the plugs are all set to a static IP reservation in the router. So, it would not be a DCHP lease renewal thing I would think.

Anyone with Unifi hardware have issues like this with WYZE plugs?

1 Like

Wow you have quite the issues. I hope somebody comes along that can help because I certainly cannot. This is above my pay grade. I wish you the best of luck and hope you get it all figured out. The Greenleaf that you were talking about was part of the Unifi correct?

Yes, in the Unifi controller, the Green Leaf icon next to a client’s channel indicates the client supports the wifi Low Power Mode. Most devices support that, like phones etc, a low power state of the devices wifi chip.

Here is an screeny of part of the Unifi client list.:


Ahh. Very nice feature to have.

Is the Airtime Fairness setting turned on?

1 Like

Don’t think so. Pretty sure no. Should it be? I have never enabled it.

I have read on the UBI forums that enabling that can cause performance issues.

I cant seem to find that setting in the controller.

Auto optimize is off. that also a setting that the fourms and many users deam do not enable as it causes issues.

EDIT: I have show Advanced feature enabled, but there is no Airtime Fairness settings anywhere. I thought i recall reading some where that that was removed at some point.

EDIT 2: AH. I am not crazy. Airtime Fairness is not aviable for NanoHD.


I have a NanoHD, switch 8 and USG and haven’t really had any issues with all of the Wyze products. Two questions come to mind…

  1. Do you have your IOT devices separated onto their own SSID and vlan?

  2. If you don’t already have the “Association Failures” widget turned on, I suggest enabling it on the dashboard. I had a bulb that had this same issue and when I enabled this widget I saw a ton of association failures. In my case I repositioned my AP and the failures dropped to zero and it’s been working ever since.

1 Like

I loose my plugs about once a month and resync but it is because of the SSI to plugs are around 58

1 Like

The 2.4 band has only the IoT devices, which is only the 8 active WYZE plugs, one WYZE bulb, and one FIET Electric RGB smart bulb. There is also a Amazon FireHD8 tablet.

All other devices, my laptop, Pixel 3, and ocassionaly other phones etc are all on 5ghz band.

I do not have any VLANs setup, it is just set to “Default” in the controller. (and I am not sure how VLAN setup works…dont u need a USG to do that?. I have never messed with VLANS)

No authentication failures. The plugs are in the same room as the AP, save one that is in my kitchen, 2 walls between it and the AP. That one does not go offline as often as the others, it appears. I have set the radio power to high or low, and all plugs still report ~98% wifi experience and signal strength. So does not seem to be a signal strength issue.

The only thing that is frequent is under Anomalies is the " High TCP latency for Client …" but that has been there and all wifi clients for ages. Been told by UBI and other users, it means nothing really and to ignore it.

My 2.4ghz environment is EXTREMELY crowed though, with over 50+ networks in range.
However, if that was the cause, then I would expect the plugs to act up when on the other AP i tempt setup and switched over to, and they dont. (And that AP is acutly a small Linksys AC750 Wifi Repeater/range extender, that happens to have a standalone AP mode.)

1 Like

One of my plugs, with the Radio power set to Medium, is RSSI -52dBm, but all others are in the -40’s or -50’s which is stronger signal…and those act up too.

I can try setting a min RSSI in the controller…but signal strength or quailty does not seem to be the issue.

I can’t see that detailed info when i have the plugs on the Linkys AP…

EDIT: I set a Min RSSI of -60dBm for the 2.4g radio, with Strict mode disabled. I see a Cell Size Tuning option as well with a dBm setting, but I am not certain what that does, it is disabled.

1 Like

I sorta remember something like that happening a long time ago at a place I worked at and they eventually figured out that another company was using the same wifi network name. The laptops were swapping between them over and over again and the credentials only worked half the time and the duplicate network didn’t show up as a duplicate.

The chances of that being the source of your problem is extremely low though.

1 Like

You can use the EdgeRouter to do vlans. It does get complicated since you will need to open ports between your subnets to allow control on your personal devices. There is a good video from CrossTalk Solutions on YouTube that goes over the process in detail with an EdgeRouter if you ever wanted to try it.

As for your current issue it might have something to do with the Wyze firmware or hardware. I noticed today that my lock gateway is having association failures. The gateway is about 20 feet from the access point and its getting -66dBm so in theory it should have a pretty solid connection. The gateway is one of the only Wyze devices close to my access point. The others are a room or more away and not having issues. I am going to move the lock gateway to another room tomorrow and see if the association failures drop off.

1 Like

Make sure auto optimize is off and high performance devices is off as well as any beta option. I also have ER and 2 nanoHD & 3 AC-M - currently only 3 plugs active - no issues. All my IoT devices are on their own VLAN. These products talk to a lot of countries (until I GEO fenced them). I’ll see if I can send you a private msg so I can share settings - if you would like.

1 Like

yes auto op and HP dev settings are off.

i did test with just 1 plug, worked fine, but with multiple plugs connected, it has issues after a while.

Testing current suggestions that was sent to me via dm.

1 Like

I have a similar problem. After I update my two UniFi switches and 5 AP’s, my two Wyze Plugs become unavailable on the Wyze app. But on UniFi app, I can see these two plugs are still connected to my WiFi. Both plugs are flashing blue light at this point.
If I force these plugs to re-connect via UniFi app, then they become available on Wyze app.

What model UniFi APs?

My Nano HD just is not useable for WYZE plugs, it matters not what firmware it has. Been this way since i made this thread back in March I see…

I have been running since then, my 2.4ghz wifi off a cheap Linksys AC wifi repeater (in AP mode) that i got at a Thrift store for $5 :grinning:. Not a single disconnect with any of the WYZE products for months.

2 months ago, I replaced that Linksys with a UniFi AC-LITE. It has been fine and no issues at all with my WYZE plugs.

So…some compatibility issue with the Nano-HD model i guess?

I am running a UDM-Pro, US-8-60W switch and a NanoHD and haven’t really had problems with the plugs connecting to the NanoHD. I have 4 plugs at the moment from Wyze and all of them have been up and running since I last rebooted my NanoHD. Make sure your NanoHD is not set to auto select a channel. If it is, you will want to run an RF scan and pick the best channel based on the findings from the scan. Also if you have Wifi AI turned on I suggest turning it off. Also, I am on the latest firmware for the NanoHD (

1 Like

save your breath…been down that road of basic nooby troubleshooting.
Like i said, it is not a new issue, has been a thing, for at least 2yrs now, i only just posted about HERE last March…9 months ago. ANd there have been many firmwares since then for the Nano, i use also many beta even alpha firmware sent to me by Ubi direct to help resolve the issue, as well as false DFS Radar issues. They even sent me a new NanoHD AP, it did the same thing.

Nothing to do with wifi settings, basic or advanced.
Not channel or power related, as the plugs never had an issue on the Linksys AP using the same channel.

The AC LITE was adopted by the controller and got the exact same wifi network settings as the Nano used for 2.4ghz…and the WYZE hardware has no issue staying connected now.

The different wifi SOC hardware in the AC-LITE, and also, the other wifi AP’s i have used with the plugs and never have had this issue, i conclude it has to be a odd compatibility issue between the wifi SOCs of the WYZE plugs and the NanoHD.

I have tried in total 4x different NanoHDs (2 from MicroCenter purchased 6 months apart, and 2 sent to me by Ubi directly at different times) new cables, all 2.4ghz channels, a brand new fresh factory reset and fresh controller install and setup. Many differnt settings tweaks, min rssi, min data rates,…a few other settings suggested by others that i don’t recal and don’t even know what they do or mean…NOTHING helped.

All 13 in total to this date, of my WYZE plugs, all bought at different places, different times over the last couple years, would after some time, hours, days, weeks, whenever, woudl blink, either one or two, sometimes all of them, sometimes one after the others every few minutes, with no internet connection, but UniFi said they connected and no issue. I had, for a while, 3 WYZE cam V2s on the same 2.4ghz wifi network and NanoHD, they worked fine, with no sign of such connectivity issues. Only the Plugs.
SO the “Solution”, for me at east, is to use a different AP.

EDIT…2yrs later: i no longer use WYZE plugs. Moved to Wemo plugs. They worked fine with NO network drop issues on the same AP. I used them for few months, then those started to have a different issue of Belkins terrible cloud connect servers just not working or taking to long to respond to engage any sort of voice commands to trigger the plugs or even read the status. Trashed them too, and moved to Lutron Castea plugs that work with my inwall dimmers and are not wifi.
TLDR. Do not waste your time with any wifi smart plugs. They are very unreliable. Go for RF based ones, like Zwave or zigbee, or something else.

I too have nanoHD and no issues with Wyze switches or cameras… across many firmware and controller upgrades over the past 2 years. This is usually a setting issue and as already mentioned - if you have Auto Optimize on - many things don’t work.

Let me know if you would like me to send you my settings

That’s really odd. You would think if it was an SOC issue it would impact all NanoHD users. I have been using a NanoHD since before I had the plugs and never had an issue with the plugs or really any other Wyze product. I purchased the plugs during EA in July 2019 and they have been working on my network since I received them. I know a few people with NanoHDs as well and they have no issue either.