Wyze plugs (2021) and TP-Link Archer A7 wifi router

I purchased an Archer A7 to provide wifi in a computer lab environment specifically for 20 Wyze smart plugs. The router is not used for any other devices. There are only a couple of other wifi networks for this lab, but they can’t be used by the plugs because they require web site login (and I don’t manage them).

At first, it seemed to be working fine, but now over time, the smart plugs seem to keep losing their wifi connection to the router and not automatically resetting and re-establishing the connection (which I think is a Wyze issue, not TP-Link), requiring manual unplugging and re-plugging (which is complicated by a global pandemic where the whole idea of the smart plugs was to not have to go into the remotely accessed computer lab).

But I’m not sure why they’re losing their connection to the router in the first place. These are 2.4GHz only devices, so I started with the default router settings. I’ve made a number of wireless settings changes, none of which have improved anything at all. I tried disabling the smart switching between 2.4 and 5 GHz. Then I completely disabled the 5 GHz network. Then I forced the wifi channel to each of the non-overlapping channels 1, 6, and 11. No improvement. The plugs will not maintain the connection.

I starting thinking that maybe it was interference and the plugs were too close together. Separating them did nothing either.

I’m using a hidden SSID if that makes any difference.

At this point, I can only assume there’s a problem with the router and that either I need to try a different setting or it simply won’t work with this type of setup and that I need a different router.

But maybe it’s the plugs. They seem to require a completely constant internet connection. If they lose it for even a few seconds (power loss, router reboot) they will not re-establish the connection.

Any ideas or suggestions?

Maybe try setting reserved/static IPs for them?

I just replaced my A7 with a AX21 because I was having bandwidth issues with around 50 total devices, but I never had an issue with them losing a connection. Everything just got slow.

I did assign reserved IPs for all the Wyze devices on both router setups (Advanced> Network>DHCP Server). It is a bit of a pain to do because you really have to do every device one by one since Wyze devices are often unable to be differentiated at a MAC Address/Router assigned name level.

Well that’s the obvious suggestion. It shouldn’t make a difference but it’s less likely it was a thoroughly tested product scenario. It’s certainly worth trying temporarily.

My SSID was hidden for both router setups and no issues. Could be helpful in the troubleshooting process, but that itself shouldn’t be causing these problems.

No improvement with unhiding the SSID. I’m going to try purchasing a Kasa smart plug to test to see if it behaves differently from the Wyze plug. I’m already tired of fiddling with these plugs and the router.

1 Like

My experience with my 6 wyze plugs is that every time I reset the router or have a power outage 2 or 3 will come back on line. The others I have to unplug and replug in to get them to connect. Seems random. It’s like they don’t try to reconnect for long enough or they are competing for the same address. I’ve tried two routers.

I installed a couple Amazon plugs and two gosund plugs and they work fine.