Wyze Plug setup trouble

Someone gave me an original Wyze Plug (not with Bluetooth). Setup stalls on “connecting … this could take a minute”.
My WiFi network has the same SSID for both 2.4 and 5 GHz, so my Android phone is undoubtedly using 5 GHz. Other postings about this issue tell me I should use my 2.4 GHz network. But is that true if both networks use the same SSID?
But also during the setup I’m supposed to connect to the Plug which sets up it own AP (access point). And I’ve done that. So the setup process is confusing.
Can someone please give me advice on how to setup?

Welcome to the forums! Tried disabling your mobile data on your phone, that may help connect to the plug.

1 Like

Turn off mobile data solved my problem - thanks!
Now I have to try that with some older Wyze cameras that currently don’t connect.

1 Like

I have the same priblem with my first gen plugs, I can not reconfigure them, my Wyze app only allows bluethoot cinfig now. Anyone knows if this will be permanent… I have 10 pluggs in use and this would make the unusable if i have to reconfigure them.:disappointed_relieved:

How is that? Don’t you have the choice to pick which plug to set up?

Apparently, that is the case!

Either Wyze no longer supports the 1st Gen Plugs, or when the app was last upgraded, the developers left off the ability to setup 1st Gen Plugs in an effort to force the purchase of the BT Plugs. Or in my case, incentivize me into a different platform.

Unless someone has a solution, it’s time to look elsewhere. This is a prime example of why I limited my initial testing of Wyze to just a couple plugs.

If you click the classic plug during setup what happens? What is your experience? I’d like to help narrow this down because the setup process should be working. Screen shots to what you are seeing would help, thanks in advance!

With the latest version of the app for Android, which was updated earlier today, the option to choose between the 1st & 2nd generation plugs is no longer available. And unlike the OP, mobile data is not an issue as I have a WiFi-only tablet. A screenshot isn’t going to help either, since there’s nothing of relevance to pass along regarding this issue. So…

Looks like you’ll have to contact support then to see how they can assist. Here is the contact info:

Truly unbelievable if this is the case- just the other day I saw the option for 1st gen plug. Now it’s gone and I can’t program any of my 12 plugs. If this isn’t fixed, it’s a crime and I’m done supporting Wyze for good. Not the type of company that would do this to force purchases, or so I thought.

Doesn’t Wyze Support monitor these forum threads? I don’t spend any time here unless I have an issue, and I don’t have time to keep coming back to see if the issue has been solved.

If an app update includes elimination of the only way to setup the 1st Gen Wyze Plug, then I need to know if this was due to an app programming error that wasn’t noticed at the time, or if this was an intentional decision. The latter doesn’t make sense unless Wyze no longer wants to support earlier generations of its products, and subsequently piss off its early adopters. With the former being the more logical position in my mind, is it not enough that Wyze customers are using this forum to point out problems with products and also offering troubleshooting options to those trying to get their products back online? Does Wyze actually expect customers to do everything? Do they expect customers to happily accept when their products will no longer receive support, especially when there wasn’t any notice given ahead of such a decision? Is this one of Wyze’s business philosophies!

1 Like

The 1st gen plug can still be set up. I just did one today. For some reason the app defaults to the 2021 version setup. Just hit next then wait 1 or 2 minutes (yes this sucks). The app then will ask to check your plug and then pick the 2021 or the classic plug. It sucks, but still works.


Can confirm: waiting works to set up the classic plug. Not sure why the choice for the ‘classic’ plug doesn’t pop up right away anymore, but would be nice if there was a note during the set up process or something to inform users of this.

Thanks for taking the time and effort to offer your help, unlike those making money on products they sell, but no longer support.

Unfortunately, the method you described didn’t work for me on my Samsung Galaxy "WiFi-only tablet.

When the “Next” screen came up, I clicked on it as suggested, which in turn brought up a couple of options to choose between, “No Thanks” and "Go to Settings, but rather than choosing either, I just waited a few minutes as suggested. When the previous app version didn’t show up with the Classic Plug option, I decided to try it again. This time I waited more than 20 minutes while I worked on other things. Since waiting longer didn’t make any difference, I tried everything else I could think of including power-cycling the plug several times, clearing the app’s memory cache, clearing my tablet’s cache from the recovery partition, then uninstalling/reinstalling the Wyze app, and finally balancing on one foot while tapping on my head with my right hand and rubbing my belly in a counterclockwise motion with my left, while singing “I will Survive”. Nothing worked. This is so ridiculous!

So it’s been 12 days since my last post, and over a month since the option to get my Classic Plug back online through the app was removed by the developer.

After each of the suggestions to work around this problem by other forum members failed, against conventional wisdom and experience, I decided to see if Chatting with a CS rep would help me to get the Plug reconnected to my WiFi network. As hopeful as I was that this route would surprise me, it didn’t.

At least management chimed in with their concern. Unfortunately that concern was not directed toward my need for assistance. Instead it was to make sure the CS reps were doing right by me. If rating the reps on friendliness, patience and knowledge is the desired goal, the first rep would receive at least 4 out of 5 Stars by me, and possibly 5 if our chat didn’t have to be cut short in order to retrieve some requested information from the same device I was chatting on. Conversely, I would honestly have to give the second rep a 2 based on impatience, not paying attention to details, and what seemed to end up being a general lack of knowledge about the problem at hand, a problem that remains unresolved. I doubt this post will make any difference, but…

1 Like


Wow, thanks for sharing that experience and for the effort. I’ve been following this for while and am all settled in a new home I had built with the idea of expanding my Wyze products. To my surprise, after obtaining newer products and installing everything, the must trusty / easy to setup / simpler(?) hardware devices (my smart plugs) are the ones that failed me(?).

Prior to that I only had one motion sensor to fail to re-connect to a bridge.

Come on Wyze, we’re your fans we help with all those pre-orders of new products. You should be listening to us, the sugar high of the infusion of cash from investors wont last always. Keep your loyal base happy and not feeling like they’ve wasted money. Just sayin.


Second that, listen to your customers do not make it harder for us to use the products we bought from you when you were just starting…


I agree with you. The setup procedure with the old style Plug is a royal pain in the butt!

I’m trying to add a Plug now and can’t get past the Location Services screen. I click NO THANKS and it just keep asking to goto Location Services on my phone and make sure the Wyze App has location permissions.

I checked a thousand times and the Wyze app has Location Services Permissions.

Why am I unable to click NO THANKS to Location Services and continue!!!

I’m shocked that Wyze has never fixed these issues.

I’ve reset the Plug to factory defaults.
I’ve made sure the Wyze app is up-to-date.
I can see the Plug SSID from my phone and tablet.

I am so frustrated with this product.


1 Like

I second the frustration. Is there an official statement declaring the classic plug a huge time suck with no satisfaction. I had 2 working great and bought 3 more to have them all brick with an update, BS

1 Like