Wyze Pan Cam unusable after firmware update

Worked great until, Now when I launch the cam it goes through the 3 step process like normal. Once connected I get about 3-5 seconds of video and then it drops out. When it drops I am greeted with the connection failed.

  1. Force Close the App (Done this about 100 times… lol maybe more, tried on a secondary android device to encounter the same problem.)
  2. Restart the camera, I’ve done this both through the application and via the ole cord pull and wait. Both methods failed to resolve the issue.

I have two non-pan cams that I run the RTSP firmware package on that work like a dream.

Does anyone have a solution to this issue? Is it possible to roll the camera back to an older firmware version?


1 Like

Yes, you can reload the current firmware, load an older version of firmware, or even load RTSP like on your other cams:

An SD card is required for this process. Most any size will do:

  1. First, go here and download the Cam Pan Firmware (you already have RTSP):
  1. That should give you a “.bin” file. Rename it to “demo.bin”.

  2. Put that demo.bin file on the SD card in the root directory.

  3. Power off your camera, insert the SD card.

  4. Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds.

  5. Once the light is solid blue, release the button and wait for 3-4 minutes. The camera will reboot and change light status during this time.

After it is done, your camera (hopefully) should be functioning again.

If not, you may want to submit a ticket:


Excellent I will give this a go, wasn’t sure if it would accept an older firmware in the same method as it did with the RTSP firmware.

Thanks for the guide!

Thought I would report back in case someone else runs across this, I gave the newest firmware another shot at install, same result.

Rolled the camera back to

The camera now functions as it should,

Thanks @Newshound for the quick reply and help!