Wyze Pan Cam not working with newer Android versions

I have a Wyze Pan Cam with the latest firmware (installed recently).
I use a:
-Motorola phone Android version 8.0.0
-Galaxy TAB A Android 8.1.0
-old ZTE phone Android 5.1.1
-old Tablet Android 6.0.
All 4 have the 2.4.82 (updated recently) version of the Wyze app.
Around June 23 I started having problems with the camera. It would not respond to the app instructions and would freeze, etc.
I tried using the older phone and it worked very well. The same with the old tablet. I only have problems with Motorola and the Galaxy!!! Seems like the camera doesn’t work with newer Android versions; it worked before.
I had help from one of the Wyze techs but things remain the same.
I’ve reconnected the WiFi (2.4) but nothing helps.
Has anyone experienced similar issues?
Please let me know if you have ideas to solve this problem.
Thank you,

All I can tell you is the pan cams I have Work with my devices with Android versions 7, 8 and 9

Keep in mind that this forum is primarily a user to user community. If you don’t get a helpful reply here, please file a Support Request. Depending on the nature of the problem, rather than use the website link, it is helpful to submit an App Log and/or a Firmware Log.

It could be a bad camera that needs to be replaced.

Not sure what your problem is, but I have been using the Wyze App on an Android Essential phone with Android 9 and it works great.
Sometimes a Storage cache dump or Factory Reset are needed to get Apps working again.
Just too much junk accumulates in the cache partition.