Wyze Outdoor seems to be dead

I recieved my Wyze Outdoor a couple weeks ago, but did not have time until this past week to try it out. First day was ok and I did a 2 hour time-lapse. Second day, I recharged the battery to 100% and set it to do a time-lapse for 7 hrs @ 1 frame every 1 minute. I left to do some erronds around 4 hours latter and the camera was as ~70%. Came back about an hour later and the camera was at 0%. Now it will not take a charge. I have a $50 paper weight. I have tried several times to charge it but cant get it to take.

Is there anything I can do or do I write this purchase off as a bad learning experience? I was going to start with 3 outdoor cameras, but now I am very glad I only bought the one. (or wish I had not bought any).

This does sound like a faulty camera.
See if the red light comes on a when you plug the camera in. If the light comes on let the camera charge for 2-4 hours and see if it works.
If it doesn’t then I’d contact Wyze and get a replacement.

I’ve had it plugged in for a couple hours and still can’t connect. I’ll leave it plugged in today and if still no joy, I’ll contact wyze support. Thanks.

1 Like

Hi Charlie, we have support and warranty on our product. So don’t worry about “write off”.

I suggest -

  1. making sure using the supplied cable and base station to charge.
  2. Pay attention to the camera status light. It should be blinking red when charging, and solid red when fully charged.
  3. If the light is NOT on, when charging, It is most likely a defect unit. Pls reach out to our support.

To understand more - when you did the timelapse, was it outside ? was there any rain conditions ( make sure the charging port and SD card seals are all sealed, otherwise, water can get in ) ?


Yesterday was a bit wet, but we were careful to place the camera where it would not be hit by rain or winds. As soon as I realized there was a problem, I inspected the camera carefully being sure that the protective flaps were in place. There was no moisture that I could see.

When I try to charge the camera, the status light is flashing red. After a few minutes, it stays red.

as long as the sealed are all properly sealed, it should be OK with rain, as it is IP65 rated.

If the light is solid red, it means that the camera is “fully charged”. How did you tell that the camera did not take a charge ?

The app shows 0% and I can’t connect to it. After a while the status light just goes out. I can’t ping it or connect through the app. Should I try deleting the device in the app Nd try to set it up as new?

It’s got to be a defective camera. @WyzeDongsheng will help you out!

Let me clarify - if you plug the camera to power, the light will blink red, and then become solid red. But after a while, the light will go out ?

i seem to be on two different threads. Dont’t know how to combine them.

It appears that the issue is with the wallwart that came with the WO. It would come on blinking and 30 seconds latter it would go solid red. After a few minutes more, it would go out completely.

I found an ipad wallward (5v 2.5a) and tried that and now it’s charging. If this successfully charges all the way, I would like to get a replacement for the wart that came with the camera. Is that possible?


yes, pls contact support. it would be greatly helpful if you are able to found the defect part.

1 Like