Wyze - OLD & NO Password still accesses APP & Cameras

We changed our password for our Wyze account.
Yet we are still able to access the account, app and all cameras using the old password.
We even deleted the password from the iPhone and can still access the cameras via the app.
Completely deleted the OLD password in settings/passwords on the iPhone, NO password and the iPhone still accesses the app & cameras.

This my be a small security issue.

I just tryed it out and it will not let use,

Did you change your password on one device and try to access the app with a separate device? We are using an iPad for email & forum, as well as the Wyze app. Then we tested the iPhone as a secondary device. The new password is in the iMac, the iPad and the forum, as well as the Wyze account. The iPhone is still able to access the Wyze app and view our cameras even after deleting the password in the iPhone settings. The iPad with the new password is also sable to access the app and cameras.

Will do further testing later,

Thanks for your reply.

Log out of the account on the iPhone. Then try to get back with the old PW - bet it does not work. As is common on MOST login systems, once you are logged in, you are in for some amount of time unless you specifically log out. Had you waited a while and tried it, you would have timed out and would have to log in again. I recall someone determined that it was about a week. Not confirmed by me.


Okay, that was the case.

Thank you for your response. It solved the mystery. The part which was most puzzling was after the password was deleted, and we force quit the app, it would log right back into the app and view the cameras.

Update: We disconnected from the ISP and dropped all connections. That should now require a current password for all new connections. Changing the Public IP is also an option if you are not running servers or you have DNS pointed to the IP, which would create its own set of problems.

Thanks for all the help.