WYZE MESH ROuter with Static IP on Fiber line

I am trying to setup My WYZE Mesh Router with Static IP but its not working I have contacted Support team but they are understanding the Issue and cannot help me. Every time I call i do same steps. all over again send screen prints. I have feeling the Router is not tested with Static IP setting.


Static IP from your Provider? or Your Own Static IP in the house?

WHen you go into the Mesh Router, you click on the Gear Top right, then Advanced Settings, then IP Address

Once there click WAN IP and Select the Option for Static IP if you have a Static IP from your Provider.

If you want to change your IP scheme in your house, as I have, you would Click on LAN IP and select Manual DHCP.

If you want you can utilize the WEB Interface by going to https://XXX.XXX.XXX.XXX where XXX is your gateway IP address. This will bring up a logon screen to the router. The default User ID and Password is on the label on the bottom of the Root Router.

Proceed to WAN Settings and set it up as you need from here as well.

1 Like

Static IP from Provider

Have you tried the Static IP Setting in the Router? If you have, try doing it from the Browser.

Can you provide a bit more information as to what you are seeing?

Yes, I have tried setting up Mesh Router with Static IP atleast 20 times. it just loading.


sorry, but we can’t assume anything these days. That’s the reason for this question. @spamoni is going to give you THE BEST info. But, still need to ask. Has your provider assigned a specific address to you? I mean, you have something in writing or email that locks your home/modem in to get a specifically assigned IP address? Or you you simply trying to permanently use the one your modem has grabbed?

And I am not trying to get you to reveal it. Do not post the info. Just asking indirect questions.

1 Like

yes, I have pool of IPs that is given to me and its working fine with other router but not WYZE.

Great question.

If indeed the provider provided a static IP, you may need to reach out to them as that IP may be tied to the Mac Address of your other Router. In this case, they would need to register your new device with the Provided IP.

Have you tried using the Browser access method and not the App?

1 Like

I have contacted them already it not tie to anything

Ok. Try using the browser to see if it works. I will check to see if there is something special needing to be done

Can you also provide screen shots if what you are doing along with any popup screens.

Please provide the ticket number from when you called support, I will also add it to the escalation process.


Have you tried any of the other pooled IPs provided?

Asking because the original one may still be tied up with the other router unless you did a release on it or the TTL has expired.

ticket # 2675289


Will escalate a bit later.

What about using the browser to see if you have success?


Added to Escalation Log

Hi spamoni4,

Your idea worked. I setup as DHCP in to existing router then through app change it to Static IP and restart it. it picked up the setting. thanks

Thanks again.


Glad it worked for you.

Enjoy the router, mine has been working great

1 Like