Wyze lock constantly losing calibration and burning through battery life

Hello @Romeiro,

Thank you for reaching out, much appreciated.

I found your feedback log and I am sending it to the dev team for investigation. Thank you for doing so.

So before the firmware update, you didn’t experience constant calibration issues? Do you know if your lock use case has changed recently?

Thank you for answering my question.

Have posted this on several of these issue areas n I am hoping for help too.
I need to chime in. I have had this issue from the start. I got my lock in Dec. I have to calibrate it often. It’s so scary that my wife believes it’s working n leaves but lock not locked as door says open but its closed.i even last week got finally a replacement lock n it did it out of the box. All updates, all required install, all things correct but still happening. When I called back in jan they said on phone they were aware of issue n working on fix. Well its 6mo later still an issue. When I started calling or doing support again as phone does not work I had submitted a bunch of door status logs. No one can tell me what problem is n now that its happening to this replacement I am worried that there is something that they r not telling me. I have been a big backer of wyze but this is a serious problem n needs to be fixed as it’s a safety issue. I had been dealing w Marczeus at wyze but have not heard back in a week on this new lock having same issue. Someone fix this it’s a serious safety issue.

1 Like

So, support, after sending them logs and going back and forth, essentially just said “we’re hoping an update fixes this” and that was all. It’s a bummer, to say the least, that we can’t get a real answer of this problem and forums vs support seems so detached.

If I don’t leave my door open for more than 20-30 seconds, it doesn’t have an issue. Anything past that, and I need to calibrate it again. I even tested it again right before typing this message out. It’s still a problem with the firmware I’m on.

Auto unlock doesn’t work, I can’t leave my door open, had to turn off all alarms for it before of the calibration issue. Needless to say, I won’t be purchasing any more products until this one gets fixed via new hardware or firmware. Not to mention I now have to factor in replacement batteries for the lock. I changed mine days before this original post and you can see the level they’re already at in the screenshot.

Same issue. I had the early access lock. It wouldn’t even calibrate. Got a replacement and we’ve had to recalibrate so many times. We got tired of it and always had the door open status on the app. Which also turned off the auto lock feature.

Now with quarantine, we took the time to recalibrate. We have kids here so there are plenty of times the door doesn’t get shut all the way. The alarm goes off and I shut the door, but then I have to recalibrate.

And then last night at 1am my log shows my acct auto unlocked the door. This was very concerning.

We have to recalibrate a few times a week. Sometimes for no reason, other times because the door is left open for a few minutes.

Why does it have to recalibrate if the door is left open?

I’m thinking I’ll just get the keypad and not worry abt the auto lock feature and just leave the thing uncalibrated… Although I sure love being able to confirm the door is closed from my app.

Wish this worked better.

1 Like

Hello @cramerjm, @timtapscott, @zeelog, @westpw1, @catyo,

We currently are trying out a potential fix for this issue. This will require installing a test firmware for your Wyze Lock. If you are interested in helping us testing the fix, please do the following:

  1. Private message me your Wyze Account email and S/N of your Wyze Lock that is experiencing this issue.
  2. What smartphone are you using? Android or iOS?
  3. Are you in the Wyze app beta program? If not, are you able to sign up?

Your support and participation are greatly appreciated. I apologize for the product experience so far. We will get this fixed ASAP.

Hi Jonanathan:

  1. Any developments to my last response with version #s of the WyzeLocks and the Wyze app?

Status Update:

  1. Auto unlock (BT) does not happen - instead, I have to use the Wyze App (wifi) and then unlock - least time is 23 secs and more some times. Keypad - no issues.
  2. If the door is left open for more than a few minutes, the Wyzlock goes into “lockdown” and needs to be recalibrated. But this may be a known issue - I am not too bothered by it.

Once I hear back from you, I can then try and link Alexa and try some advanced stuff!




Hello @zeelog,

Can you private message me your Wyze account email?

We currently are trying out a potential fix for the calibration issue. This will require installing a test firmware for your Wyze Lock.

My Wyze Lock does the same as the others. Constant calibration needed and “open” status all the time, it’s very annoying. I hope this gets fixed soon.

Hi Jonathan:
Any updates on the Wyzelock firmware version that fixes the “Calibration Required” issue? I did send you all my info including app/wyzelock versions + login user name.



I have the same problem. We leave our door open for long periods like outside working. We use the lock manually a lot, but everytime I try to use it it wants to recalibrate. I can still lock and unlock with the app but it will constantly nag at me until I recalibrate it. I don’t have specific timelines however this should not be an issue nor hard to find. What triggers a recalibrate? Answer that and you find the problem :slight_smile: Sorry I know I am over-simplifying.

Hello @zeelog, we are planning to release the test firmware later this week.

Hi @JonathanF - thanks for the update. Will this also resolve the Auto-Unlock issue (caused due to Google Maps issue) just asking :slight_smile:

Any ETA on that update? I have having this issue for quite a while on both of my locks.

Please sign up to test this lock firmware:

Thanks, I just signed up. Fingers crossed that this fixes it!

Someone has received the new beta firmware update ? I sign up to test this lock firmware, but I still not receive any update on my app.

I signed up 6 days ago but I still have not received it either. @JonathanF Is there any ETA on when we can expect to receive the beta firmware after signing up?

Just reporting my experience. I replaced my early access lock batteries for the first time today (July 14) lock was installed Jan 9 The batteries were still showing 7% but the lock was reporting door open status even when it was closed. Auto lock and auto unlock have been disabled since late January. I tested the features for two weeks and it was working but have it turned off due to the mannerisms of other people in my household. The lock itself is rarely unlocked/locked remotely maybe 3 times a week. I have not had to recalibrate very often. Maybe a few times the first week, once maybe 3 months later (I think lock was reporting incorrect status at that time as well) and once more after I put new batteries in. After I installed the fresh batteries the battery life did not update and it was still reporting open when closed. Battery and status were correct after I recalibrated.

I do not have the keypad yet but plan on getting one eventually.

I am having the same issue now In August 2021. Any idea what the problem could be?

Yeeeaaahh… cold day in hell on that! :rofl:

It’s not that they don’t read their forums, it’s just that they don’t care!