Wyze Headphone - Not working on iPhone after Firmware 2.1.82 upgrade

I just did a firmware upgrade to version 2.1.111 today on Wyze app. Since then, I can no longer listening music on my iPhone through Wyze Headphone. It only plays the music for about 2-3 seconds then no more sound. Anybody else having same issue?

I am on iPhone 11 Pro running iOS 14.2

I likewise attempted a firmware update on 12/30/2020. The headphones turned off and will not turn back on. I attempted everything I found on the WYZE site as well as everything I could find on the internet and anything else I could think of. The headphones are dead. This was very disappointing as early the next morning I had to catch a flight and I had no headphones (and especially no noise cancelation). I was hopeful that somehow, when I returned on 1/6/2021 that the headphones would somehow work. They didn’t. Wish I had not tried the firmware update. My WYZE app indicates that the current headphone firmware is 2.1.111 and the latest version is 2.1.112. I have no idea which version is in he headphones because they are dead. A full charge does not make any difference. (Iphone 12 Pro Max iOS 14.3)

Some things that you can try:
• Have you tried delete the device from Wyze app and re-pairing it?
• If you connect the headphone via cable to computer, does it work?

I can hear sound when I hard-wire the headphones into a source using the jack. The headphone power button will not turn on or light up. The volume buttons don’t work. The noise cancellation button does not work. I can increase and decrease the sound level by using the volume control on the device that I’m plugged in to. Even when I can hear sound (music) while plugged in, the headphone sound turns off and on randomly, but the controls, including the power button on the headphone never turn on – not even randomly. I deleted the headphones from the WYZE app. I cannot add them back to the app because they will not turn on so that the app can find them. Even with continual attempts (in the hope that somehow the random off and on sound makes a difference), the headphones will not turn on. The headphones worked great and I loved them until I attempted the firmware update. They have not worked since. Plugging into the computer can give me on and off sound, but that is all.

What about press and hold power button for about 15 seconds. Does it do anything? It is supposed to perform factory reset.

Tried it. It did nothing.

Looks like it is indeed a lemon headphones. I would contact Wyze support.