FYI headphones firmware 2.1.112 update "failed"

so tonight I got a notice to update my new headphones firmware. this update ( mainly because it appears to be fairly large and is connected and delivered to the headphones via Bluetooth) says it can take up to 30 minutes even though it only took a few minutes. so I can imagine many like me getting distracted easily.

I did the update on 2 sets of headphones and each time got an “update failed” notice. I’m writing this as notice to new users or people that may have not run into update failed notices before. Don’t worry. if you got this notice after attempting to update just go into the apps Account.>firmware update page and check your headphones firmware. check to see if it is up to date or shows and update available. even thought I got a “failed” notice, here is what my page showed. the 2.1.112 update went through.

we have run into this in the past of doing an update on cameras and other devices and getting a “failed” notice only to find that the update did in fact go through. this has lead to frustration from users thinking the update didn’t take and forgetting how to check things in their frustration. because I got the notice twice I figure there are others running into this and maybe I could forewarn them.

the headphones alone have attracted many new users to wyze and hopefully this can help them if they run into this small hiccup. :sunglasses:


I ran into the same problem. Firmware 2.2.112 update failed and I got the message to try again. Like @Bam mentioned in the Account > Firmware Update it shows the firmware is up to date, however when I click on the Headphones device on the Wyze app, I get a blank page! I tried to delete and add the device again, stop the Wyze app, clear the cache and the storage of the Wyze app in Android, reboot the phone. Nothing. I haven’t tried to re-install the Wyze app yet, as stopping the app and clearing the cache and storage should suffice. Any suggestions?

Happening to me too. Im hesitant to uninstall app as I believe it deletes all the device settings.

Actually, I ended up uninstalling the app and re-installing. It still did not work! You are not going to lose your setting. Your setting are stored in a Wyze back-end server and the app talks to the back-end server via APIs. Just to prove that, install Wyze on another phone, log into your Wyze account and all your devices will appear again. Which is exactly what I did, install the the Wyze app on another phone and the Wyze headphone appeared along with all the settings. It’s not clear at this point while it still does not work on the first phone. I even ran CCleaner to get rid of any temporary files, caches and the like. The only and perhaps not so subtle difference is that the first phone is an Android and the second phone is an iPhone. I’ll keep investigating.