Wyze camera doesn't like power surges

Third time this has happened. Why is this camera SSSSSSSOOOOOO hard to get booted after a power surge? Seriously. It’s annoying. I unplugged/plugged in twice now. Nothing.

Have you tried plugging it into a surge protector to limit the surges it gets hit with?


I had 4 surges within half an hour - thankfully there was no harm to my 4 Wyze cams (I had to reboot a different brand of camera twice).

Your best bet is to get a surge protector…

OK. But how do I get the camera back on?

Have you tried a different power supply?
In most cases, the device is not faulty. but the power supply (taking the hit).

Yeah. I think there’s is something wrong with it.

I think what he’s asking is do you have any other 5v USB chargers you can swap it for to see if that is your problem.

I moved it to a different power source. It turns on and says “Ready to Connect”, I point it to the phone to scan QR code, but I never see flashing yellow light like the manual says should happen.

The sequence should be: Power, yellow flashing light, hold setup button until beep, “Ready to Connect” voice prompt, enter network info into app, scan resulting QR code from at least 5 inches away.

So if you aren’t getting the yellow flashing light after you first power it up, you should probably enter a ticket with support. Sounds like it may not have survived the power surge, but they would be the official word on that.


1 Like