Wyze Cam v3 4.36.10.2700 and Wyze Cam Pan v2 4.49.3.2705 firmware released

First off, thank you for the quick responses.

I did all the steps and no change. I’m not getting notified.

Regarding the lights, the way it was working before the update is: when the camera was switched on, the light remained off until movement was detected and then the light would be blue - then back to no light after the event was complete. I cannot recreate this behavior no matter which way the camera light is set. Are you saying that with the camera light on, the expected behavior is blue with no motion and red during motion? What’s the expected behavior with the camera light off?

I have 2 cameras. The detection settings for both are working as the light changes to red (with the camera light on) when they detect motion.

There are 2 different Event Recording pages - one has “Record Motion Events → All Motion” selected and the other has “Detects Motion” toggled on - for both cameras.

For Notification settings:

The Notification toggle is on for both cameras.

The active Motion Events selected for camera 1 are Person, Pet, Vehicle, Package and Other.

The active Motion Events for camera 2 Person, Vehicle and Other. Pet and Package are disabled for this camera for some reason and cannot be selected.

Also note: even though Notifications and Event Recordings are both enabled, at the bottom of the “Device Notifications” page, it says: “You can’t turn on notifications until you enable ‘Event Recording.’”

Update: I decided to restore one of the cameras to factory settings then set it up again and I’m getting notifications again for that one. But I can’t recreate the behavior I had before where there was no light on until it detected motion - then it was blue while motion was occurring. I’ll do the same for the other camera.

Is there any way to go back to the previous firmware version?

1 Like

Glad it is notifying again.

Yes. This is how the light is supposed to operate when the status light is enabled. Blue when idle, red when either live streaming or recording a motion event.

With the Status Light toggled off, it may show up red very briefly when power cycled, but as soon as it gets it’s settings from the cloud, you should not see the status light at all for anything. It is off.

You should only have one Event Recording Page and one Smart Detection page:

Not sure what page that is. Can you post a screenshot? Are these being used with a spotlight or floodlight?

If a Smart Detection AI selection in Event Recording is toggled off, the same selection will be greyed out and inaccessible in Notifications. Note my Smart Detection selections above that are off can’t be selected for notifications below:


In order to select them for Notification, they have to have been selected for recording in Smart Detections.

One exception to this is if you have both on, then turn it off in Smart Detection. It still stays on in Notifications. I think this may be a bug. If you toggle off the notification, then the Smart Detection, it becomes inaccessible in Notifications again.

Correct. So long as there is even one greyed out inaccessible notification toggle, this message will appear in reference to the greyed out notification toggles. It is just reminding you that you can’t turn those greyed out notifications on until you enable them in the Event Recording page.

Yes. You first have to download the .zip file of the version you want by clicking the version number you want for the cam from the Release Notes & Updates page:

If a version is not blue, you can’t download it. (search the forum instead…users have them :shushing_face::wink:)

Then you have to flash the cam using an SD card with the .bin file contained in the .zip

2 Likes

Here are the 2 Event Recording pages:


Is page #2 (the one with the cam plus logo next to “Smart Detection) accessed through the warning when event recording isn’t enabled?

Yes

I have been having a lot of issues with the software detecting motion but not identifying it as a person or a vehicle. The cameras are in the exact same place they were before the firmwa re upgraded and the detection rate was much higher before. I had to disable AI only and turn on all motion detection to get the cameras to actually record the events and notify me

1 Like

Took a look at my app. When I click on the warning link on the bottom of the Device Notifications page, it takes me directly back to the Event Recording page I posted above with the new options (your first screenshot). I don’t get the second Event Recording page you posted with only the Detects Motion and Detects Sound options.

That actually looks like the Event Recording settings page that is in the pre .2700 firmware. Definitely not the one you should be seeing with the new AI Event Recording Only options (the first one you posted).

BUT…there are 3 big differences to what I am seeing and what you are seeing:

  1. I am on Android, you are on iOS. Different app builds so this may be an iOS bug specific to the iOS app and how it directs that link. I can’t confirm that it is there because of this.

  2. I am using and testing the next Beta App to be released. Definitely a different build from the Public Release App you are probably running.

  3. I am no longer on .2700, I just updated all my cams to the Beta .2864 for testing, which means I can’t confirm it there either

:man_shrugging:

I think it’s the iOS vs Android thing. I am seeing the 2 seperate event recording pages as well, have been since the update. I’m on iOS.

UPDATE

WAIT! This may have been fixed on the beta #3 that was just released! It seems it has for me, anyone else on IOS can confirm?

1 Like

Thx for the iOS assist. If it was in Beta #2, then it is also in everything before that to include the Public Release app.

Beta #3 hasn’t populated to Android GPS yet.

1 Like

I am 2 weeks into the upgrade an several of my cameras no longer can tell a person or vehicle from motion. This upgrade has degraded the AI considerably from the previous version. PLEASE get an update to resolve the AI issues. I uploaded 5 screenshots, which is the limit. Some show a vehicle in the image with the app showing detecting only motion. Others have a person in view that sometimes app detects a person, other times only motion or even a pet.





1 Like

Check in your cams event recording settings, make sure the settings didn’t get messed up in the update. If they still look right, try toggling everything off and back on. If it still doesn’t work, try removing the cam from cam plus and adding it again.

1 Like

My person detection on my v3 cams stopped working after the latest upgrade so have to now go through all my motion events.

I’ve tried toggling settings off and on and restarting a few times.

4.36.10.2864 came out this week and fixed my AI detection issues on all 11 cameras.

Charles

2 Likes

Thanks! I removed cameras from cam plus and re-added them and person detection started working again! I’m wondering if I should be doing this after every firmware upgrade to be safe.

I see what you mean about the red light. A blue light used to come on when motion was detected and be off the rest of the time. Now it’s a solid blue light all of the time that turns red when it detects motion. I did not have any of the issues with my monitoring or person detection though, just the light changes.

I wanted to report this in this thread as well regarding the WyzeCam v3 firmware 4.36.10.2700. I also opened a support request and added these details but saw this thread and wanted to post this here as well.

Bigger issue:
I updated all 5 of my cameras to this latest firmware but I think I have to flash my cameras back to the previous version of the firmware because my network keeps getting crippled from the cameras constantly being reconnected and re-assigned their same IP Address… I checked the router logs and I can see after a period of time, the camera’s will start to disconnect/reconnect from the router every minute or so and that the router is assigning them their same IP addresses over and over and over and over. (implying the camera disconnected/reconnected and was given the same IP from DHCP that it had before it lost connection) If I reboot the router and reboot all the cameras, it will be stable for a period of time, but after about 24 hours, the network starts to get crippled, things don’t load right anymore and there’s some massive delays and I see a bunch of logs for all the cameras constantly reconnecting to the router. This all started after I took the firmware upgrade on all the cameras, so I’m pretty sure that the firmware update was the cause of these issues. (You may also be able to argue there’s a router configuration that doesn’t work well with this latest firmware I guess. But again the cameras are stable for a time after both the router and cameras are rebooted, then after a period of time blow up… But since updating the firmware appears to be the trigger that started these behaviors and issues, I’m going to look into rolling them back to the previous firmware and see if it corrects this problem).

Minor issue:
I also had the same AI detection issues and fixed them by re-assigning the Cam Plus services.

1 Like

Excellent detailed description of the problem. I had this same delayed disconnect issue on my V2s but I did not research it to this level.

My V3s luckily never upgraded past “139” and the V2s recovered after being manually flashed back to “1002” firmware.

You don’t mention it your WiFi PSK password is longer that 21 characters, but that seems to be the root cause of some of these problems. Have you tried setting up a guest or test network with a short password for these cams to see what happens?

My Wifi PSK isn’t longer than 21 characters, so that shouldn’t be the issue but I can try setting up a guest wifi and segregating out the cameras and see what happens. Thanks for that suggestion.

1 Like

I can see this being the problem as one of the “fixes” of the 4.36.10.2700 firmware was improved network connectivity.