Wyze Cam v2 cannot use micro SD card

My Cam cannot read the card:

  • card has been formatted befor plug in, tried different cards
  • the cam says “micro SD not avaialbe”: however, when i unplug the card and mount it to my computer, i can see it has created a folder for today (i.e. the date when i first plug in the card) which means actually the cam is accessing the card
  • tried different firmware:, the latest one (and one another version in between, i forgot the code), problem persist
1 Like

Did you try formatting it in the camera. Use the format button in the camera and see if that works?

I had the same problem. I had to format in laptop to get the sd to work. After that the camera is able to format it. You can slip in to a phone and format it.

1 Like

You didn’t give any details about the card size or format? Having said that, the only problem I’ve had with any card was a 128GB formatted with Fat32. Once I just did the standard Exfat in a Win 7 PC, it worked fine. Same goes for a 64GB done in Exfat. The rest of the 32GB (SanDisk) I just popped in the cams without ever looking to see how they were formatted, and they too worked fine.

1 Like

Although many people use them Wyze only currently supports 32gb cards. The camera will only do a quick format on a card, which will not overwrite bad sectors, etc. The best bet is to format the card in a PC using af full or deep format. The industry standard program for this is Provided Here.
If that doesn’t work you could try a factory reset followed by reflashing your firmware.
Last but not least if you are still under warranty you can Open a Support Ticket and request a replacement.

1 Like