Wyze cam v2 cannot connect my deco m5 WiFi network

Hi there,

I just bought a wyze cam v2 and I can not connect it to my WiFi network.

I have read about switching off the 5ghz band and I did it but it still does not work.

I have re initialize all the components including my deco m5 router and i reinstalled the mobile wyze app.

Every time i got the blue flashing light in my wyze cam.

Welcome to the community, @leopoldo. The user guide on the TP-Link support pages will probably have your answer. :slight_smile:

The WiFi network is working ok. But I can not complete the wyze cam setup. Looks like wyze cam can not join the WiFi network.

We don’t have a caveat list for the cams, but here is one for the plugs. Make sure none of these items are interfering:

Page 10 of the M5 user guide appears to have a way to shut off the 5GHz network temporarily. You might want to see if that works.

I have tried all the suggestions in the list. I turned off the 5Ghz network, i reseted the wyze cam several times. I turned on the location services for wyze app. I also turned off the fast roaming feature in my TP-Link Deco M5 router, but i still can not complete the setup process.

I am really frustrated. I had a lot of expectations about this product but it simply does not work.

Well, this is a user-to-user community, so it’s probably time to bring in Wyze to see if you need a replacement or a return:



Ensure the SSID you setup on your Deco system does not have any spaces at the end of the network name. Wyze cams don’t support connecting to SSIDs that end with a space. I ran into the same issue you’ve run into and the end result was that I unintentionally added a space at the end of the SSID when I was setting up my Deco system.

1 Like

We just purchased the wyze Cam Pan.
It goes through the loading process and continually “times out “. It also says that we need a 2.4 GHz network.
I have NO switch on my router to change speed.
Has anyone else had this problem?
Extremely frustrating.

Did you manage to solve your problem? Since I have the same, I can’t connect the Wyze cam to the network. I also have a Deco M5

Deco M5 is aMesh unit.
try uNplug the meshes and left main unit alone on.

Just confirming that I was able to get my Wyze Cam Pan to work with my Deco 5 mesh. Sorry, I don’t remember the steps.

Wyze firmware
Deco firmware 1.4.4 build 20200221 rel 65392

I never ever post anything in forums but I what I read here helped me. Got a deco mesh network and wyze pan cam didnt want to connect. Took out the spaces from the ssid and turned off 5ghz and now it works!

Just got a Tp link m9 plus. After you turn off 5ghz then it worked your camera? Did you reset the camera first, when you turn back on 5ghz , the camera still connects? Thank you.

I had the same issue trying to connect my pan camera to my deco, I didn’t realize that I had added a space at the end of my network name. Got it connected right after that.

No spaces in mone other than the underscore and dash. Is this what you took out?

Legend! That’s exactly what I had done with a space at the end of my ssid

I HAVE 5 CAMS that will not CONNECT and they were fine prior to re powering them back up and now won’t connect

Had same issue with Deco M5, space at the end of SSID was all that was wrong. Removed space and connected perfectly.

I had the same problem as TP Deco was not working with Wyze! I used the internet on my mobile phone (instead of my home internet which has TP Deco router ) to solve the problem! I tried many times with the Deco 2.4 active (5.0 deactivated) and it never worked! Since I have 2 mobile phones I used 1 for the internet connection (tethered) then downloaded the wyze app on the other phone! It worked and the wyse camera recognized the 2.4 network on my mobile and I was able to set it up! I then did the firmware update and cameras worked fine! I then changed the network on the mobile phone with the wyze app to my home network and it also works! It could be the firmware update is necessary, which can only be installed if you have a 2.4 ssid! In any case this solves the problem. It is a work around since Wyze does not work with 5.0 ssids and for some reason can’t connect to the 2.4 of the TP Deco router!

1 Like