Wyze Cam v2 and RTSP

I can’t get RTSP to work recently. I’ve used it before and know how to configure it. I’ve downloaded the latest RSTP firmware and successfully installed it on my Wyze Cam v2. Numerous times. I’ve even reinstalled a previous version that I know used to work.

The app works on the phone and I can see the video. However, I cannot get Blue Iris or Contacam to view the RTSP stream. I double checked and triple checked my settings, username and password. I know everything is correct based on previous setting and Wyze documentation. It just won’t work.

Has anyone else had this same problem or have any ideas?


I have 16 V2 cameras ( firmware and two Pan cameras (FW that stream to BlueIris. As I type this, all but one V2 are connected to BlueIris - and that one is 26 miles away from my WiFi in my truck at work, so completely expected. I have a BlueIris version that was updated a few days ago.

Great to hear that it works well for you, it gives me encouragement to figure out what my problem is. What do you think of my configuration in Blue Iris?


Hey, just saw BlueIris. Does it work in factory versions of Wyze cams? I mean, don’t need to convert them to RTSP mode to use them with BlueIris.


No. Requires RTSP.

1 Like

A suggestion on the Smartthings forums recommended Kerberos.io and I was able to get this setup pretty quickly using docker on my Synology DS920+. After updating to the RTSP firmware on my Wyze cams to the RTSP firmware I enabled RTSP on each camera I used the below docker-compose file to run an instance of the Kerberos agent for each of my Wyze v2 cameras and a Wyze PTZ camera. Once these docker containers were running I browsed to the web port (ie. dockerhost:81) for each camera and setup the corresponding IP camera using the rtsp:// URL provided after enabling RTSP on the Wyze cam. Finally, in ActionTiles I added a media tile for each camera as a “This Media is an MJPEG video stream” with the corresponding camera’s streaming URL (ie. dockerhost:8891).

version: "2.1"
    image: kerberos/kerberos
    container_name: backyardcam
      - 81:80
      - 8891:8889
    restart: always
      - /volume2/securitycam/config/backyard:/etc/opt/kerberosio/config
      - /volume2/securitycam/capture/backyard:/etc/opt/kerberosio/capture
      - /volume2/securitycam/logs/backyard:/etc/opt/kerberosio/logs
      - /volume2/securitycam/web/backyard:/var/www/web/config
    image: kerberos/kerberos
    container_name: drivewaycam
      - 82:80
      - 8892:8889
    restart: always
      - /volume2/securitycam/config/driveway:/etc/opt/kerberosio/config
      - /volume2/securitycam/capture/driveway:/etc/opt/kerberosio/capture
      - /volume2/securitycam/logs/driveway:/etc/opt/kerberosio/logs
      - /volume2/securitycam/web/driveway:/var/www/web/config
    image: kerberos/kerberos
    container_name: greenhousecam
      - 83:80
      - 8893:8889
    restart: always
      - /volume2/securitycam/config/greenhouse:/etc/opt/kerberosio/config
      - /volume2/securitycam/capture/greenhouse:/etc/opt/kerberosio/capture
      - /volume2/securitycam/logs/greenhouse:/etc/opt/kerberosio/logs
      - /volume2/securitycam/web/greenhouse:/var/www/web/config