Wyze Cam Plus $99 plan - notification problems?!

Wyze Cam Plus $99 plan - notification problems?!

Has anyone else experienced problems with notifications when switching to the $99 plan? Ever since I switched, all my notifications are crazy - I’m being notified for things that are toggled off, and not notified for things toggled on. It’s like the $99 Cam Plus just does what it wants, haha.

I’ve done chats with Wyze, I’ve done phone calls with Wyze support, I’ve had emails back and forth with them. I’ve done 800 million things to try to fix the problems, including all kinds of resets, restarts, unassigning, deleting, reinstalling, etc. Nothing works. I’m told I can keep submitting logs and hope that a firmware update will fix it sometime in the future.

But firmware didn’t cause it. It was switching to Cam Plus. And now paying for something that’s broken. I’m literally not getting what I’m paying for.

I love Wyze and I’m not leaving anytime soon, but I’m seriously considering cancelling my $99 Cam Plus (at least until a new update?). Since my notifications aren’t working, I don’t see the point of paying for them?

I guess this is my last ditch effort to find a solution before I cancel. There has to be an answer out there somewhere!

Thanks in advance.

Sounds like there could have been an issue causing the app to get out of sync with the servers. Try cleaning your app cache in account > app settings, then sign out of the app, and force close it. Once you sign back in, check all the event recording and notification settings, and also check in the cam plus tab to make sure it shows as applied.

If it’s still not working, you could try toggling all the event recording and notification settings off and back on (or the opposite)

I have been on Can Plus Unlimited for a long time. But, I didn’t experience any of these issues when I did switch.

If you are up for the challenge, there are some things you can do to try to get it back right.

  1. Depending on the firmware you are running the AI notifications on each cam may be a bit different. But, go into each cam notification page and turn off each individual type of AI\Motion notification.
  2. Turn off the main notification option for each cam.
  3. Unassign each cam from Cam Plus.
  4. Clear the app cache
  5. Sign out of the app
  6. Close the app
  7. Open and sign back in.
  8. Reassign to Cam Plus.
  9. Enable all notifications.

I am sorry this is happening, this is a known issue. The good news is we have found the root cause and are working on a fix.


Wyze team, I think I encounter the same issue. What is the version of app/firmware that has this bug?

I’ve done all of that a few different times. It hasn’t worked yet, but who knows? Maybe it will work one of these times!

Is there any potential ETA for this fix?

Depending on the time of day, I can get hundreds of notifications each hour - I think my record is over 200/hr right now. But if I turn off notifications, then I’m paying for nothing, kinda darned if I do, darned if I don’t situation.

I’ve gone through these steps twice now. It doesn’t change anything. I’ve even added steps - like delete the cameras and reinstall them - and it doesn’t change. No matter what specific notifications are toggled on or off, I either get ALL notifications or I get none.

By Jason’s response above, it appears that Wyze is working on a fix. I wasn’t aware there was a known issue when I posted that. I would suspect that any steps you try won’t fix the issue until the next server update, firmware release, or app release.

I start seeing this problem (i.e. missing notification) after adding my cam to subscription. Since Wyze does not have an ETA for the fix, may be the workaround is to stop subscription and save video to sd card if you can’t wait

If you are experiencing this issue please check if it is still happening, if it is, make sure you are up to date on the app and firmware and try restarting the app and cam with the issue. We implemented a fix for this and some are reporting it is working now.


Same, there are new videos but no notification. Firmware and app are the latest. Both cam and app were restarted.

It sounds like your issue is different than the OP, they are saying they are getting notifications for items they don’t want notifications on, for instance, they want notifications for people but are getting vehicle notifications also. If you are not getting any notifications that sounds like a different issue.

Is this happening on all your cameras, which type of cameras, and what are the actual app and firmware version numbers, ‘latest’ does not help since they change quickly and there are different versions for iOS vs Android and Prod vs Beta.

1 Like

Unfortunately, I’m still having the same issues - at least I’m still getting vehicle notifications even though that option is toggled off. I’ve restarted my cameras and forced closed my app, and nothing changed. And it says everything is up to date.
V3 camera is
iPhone app is

If I keep trying to restart, will it eventually work? Thanks!

I know there is a that is a newer firmware than what you have and is in gradual release there is also another version in beta.

1 Like

I’m getting notifications that I don’t have toggled on also. Hopefully once I’m offered the latest version of cam v3 that it will fix this. I seems to only affect my cam v3 cameras. Like I only have person detection on them but get vehicle and pet notifications. I tried reaching out to support earlier this week but were very unhelpful.

Yup, I contacted support multiple times - through the chat, through phone calls, and also emails. They basically told me I could keep submitting logs, but there’s nothing else they could do for me, haha.

It’s funny that this is a firmware update fix, because my v3s were already using cam plus and the notifications were working perfectly. It wasn’t until I switched to the $99 plan that everything went haywire.

Multiple times a day, I keep checking for the new update that should fix this. But I still don’t have access to it. I’m hoping it comes soon! I don’t like wasting my money, paying for something that is broken.

My issues happened when I added another camera under my cam plus unlimited cameras plan. It reset all my cam v3s back to default detection & notification settings so I had to go to each one and switch back to person only. But even after setting them back to person detection I get all the other notifications. But I guess when it finally gives me the option to upgrade the firmware I will and hopefully it will fix the issue. I’m getting over 100 notifications a day and it is getting old real quick.

I just wanted to close this loop and say that, with the update my cameras got yesterday, all the notifications are working properly again. Thank you to the whole Wyze team!


I got the update yesterday also and it has also fixed my issues. I did have to go to each camera and update the settings after the update since it switched the setting of record all motion events to smart detection events. So I just went in and switched it back to all motion events. But besides that it works great.