Wyze Cam Pan v1 not scanning QR

I wanted to change the Wi-Fi my Cam Pan is connecting to but I can’t pass the “ready to connect” status. I tried resetting a couple of times, also unplug - replug power. I tried cleaning the camera with a micro fiber cloth and also my phone’s screen. I tried keeping my phone to multiple distances while reading the QR code but the camera won’t read it.
Any other ideas I could try?

Print the QR Code and use the printed version. I have read where some of the QR Codes on the device are cut off some. It may be a resolution issues on the device.

If you can, try another device and see if it works better.

Thank you for the idea.
This is interesting, if I generate a QR code myself using one of the wifi QR generator sites the camera says “incorrect code”, though my phone is able to connect to the wifi using the same picture.
If I screen shot the one generated by Wyze app and print out the camera would not scan and continue saying “ready to connect”
Maybe there are extra details needed for Wyze on the code? :thinking: