Wyze cam outdoor wont turn on after charging

after charging 1st time cam will not turn on

Welcome to the Wyze community @billycassels!
Does the red light come on, then flash when the camera is charging? If not, what cable and power supply are you using to charge it?
Make sure the switch on the back of the camera is set to the “on” position.

1 Like

Yes it does blink then solid after full charge

Mine just did the same thing but after successfully charging it few times before. However I should mention that this time it took far less time for the red light to stop blinking when I was charging it! Also, I noticed that when it was running, the charge percentage went from 41% to zero in few hours before I removed it and charged it. My other three WCO are doing fine. Is there a “reset” procedure somewhere I can try?

My WCO won’t turn on after 100% full charge.

My other two WCOs say OFFLINE but actually they are online and they are just fine.


1 Like

If the camera still doesn’t turn on, You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

Will do… Thank you …

1 Like

Update: After hours attempting to recharge and reconnect, all the while telling me the camera is out of charge, all of the sudden the charge jumped to 99% and was able to connect to the base, and now is working fine. Still don’t understand how the charge dropped from 41% to zero without sending the customary notification that the charge is now below 20%.

1 Like

@mzayan, were you able to find a solution to your problem? I’m having exactly the same problem and am not able fix my Wyze Outdoor Cam. Any insight on how to fix this? Thanks

Well, I still don’t understand what happened, but I kept trying using different charging adapters, different charging cables, and even charging from different outlets, then all of the sudden it worked!

Having this same issue, fully charged but won’t turn on and no light indicator anymore

Did you ever figure it out. I just charged mine foe the first time and now nothing.

Well, I don’t know what finally made it work, but I kept fiddling with it, trying different adapters and even different outlets, and over a few days, then it finally worked. I even thought it could have been overcharged and trying over a number of days allowed it to leak a bit, if that is a thing.Worth trying!
Good luck.